Bug 25588 - До установки Thunderbird (3.1.9-alt0.20110409) нет требования обновить libnspr и xulrunner, а при установке из-за старых версий получается ошибка (неразрешимые зависимости)
: До установки Thunderbird (3.1.9-alt0.20110409) нет требования обновить libnsp...
Status: CLOSED FIXED
: Branch p5
(All bugs in Branch p5/cross-component)
: unspecified
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-05-07 09:20 by
Modified: 2012-09-14 18:27 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-05-07 09:20:25
ШАГИ:
1. Поставить AltLinix Desktop KDE 5.0
2. Подключить репозиторий p5.
3. Отметить для установки thunderbird (версия 3.1.9-alt0.20110409) в Synaptic.
4. Нажать "Применить" в диалоге "Добавить в очередь необходимые изменения?"

НАБЛЮДАЕМЫЙ РЕЗУЛЬТАТ:
3. В диалоге "Добавить в очередь необходимые изменения?" предлагается добавить
для обновления пакеты:
libnss;
libsqlite3;
libvpx;
mozldap;
nss-utils;
sqlite3.
4. Появляется диалог:"Невозможно отметить все пакеты для установки" следующие
пакеты имеют неразрешимые зависимости:
thunderbird:
 Зависит от: libnspr (>= 4.8.7-alt0.M50P.1)
 Зависит от: xulrunner (>= 1.9.2.0)

ОЖИДАЕМЫЙ РЕЗУЛЬТАТ:
3. Пакеты libnspr и xulrunner-2.0 также добавятся в очередь обновления.

ПОЯСНЕНИЕ:
текущие версии:
libnspr 1:4.8.2-alt1
xulrunner 1.9.1.5-alt1.20091106
------- Comment #1 From 2011-05-08 12:01:37 -------
Используйте не Синаптик, а штатные средства обновления:

apt-get dist-upgrade
packageinstall

Скорее всего, Синаптик обновляет через нерекомендованный apt-get upgrade.
Поэтому 
Синаптик не рекомендуется.
------- Comment #2 From 2012-09-14 18:27:13 -------
На данный момент данная проблема исправлена.