Bug 26104 - crashes on a site
: crashes on a site
Status: CLOSED NOTABUG
: Branch p6
(All bugs in Branch p6/midori)
: не указана
: all Linux
: P3 major
Assigned To:
:
: http://unix.stackexchange.com
:
:
: 26105
  Show dependency tree
 
Reported: 2011-08-17 16:42 by
Modified: 2011-08-17 17:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-08-17 16:42:05
midori-0.3.6-alt2
$ rpm -qa '*webkit*'
libqt4-webkit-4.7.3-alt2.M60P.1
libwebkitgtk2-1.4.0-alt1
$ 

$ midori http://unix.stackexchange.com
Не удалось загрузить настройки: Нет такого файла или каталога

(midori:16405): GLib-WARNING **: GError set over the top of a previous GError
or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before
it's set.
The overwriting error message was: Файл пуст

** (midori:16405): WARNING **: Error: JSON.parse requires at least one
parameter

(midori:16405): GLib-CRITICAL **: g_key_file_load_from_data: assertion `data !=
NULL' failed

** (midori:16405): WARNING **: Недоступен корневой сертификат. SSL сертификат
не может быть проверен.

(midori:16405): GLib-CRITICAL **: g_markup_escape_text: assertion `text !=
NULL' failed

(midori:16405): GLib-CRITICAL **: g_regex_replace_literal: assertion
`replacement != NULL' failed

(midori:16405): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16405): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16405): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16405): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16405): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

** (midori:16405): CRITICAL **: void
webkit_web_frame_load_alternate_string(WebKitWebFrame*, const gchar*, const
gchar*, const gchar*): assertion `content' failed
Ошибка сегментирования
[imz@linux ~]$ rpm -q midori
midori-0.3.6-alt2
[imz@linux ~]$ ulimit -Sc 200000000
[imz@linux ~]$ midori http://unix.stackexchange.com
Не удалось загрузить настройки: Нет такого файла или каталога

(midori:16502): GLib-WARNING **: GError set over the top of a previous GError
or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before
it's set.
The overwriting error message was: Файл пуст

** (midori:16502): WARNING **: Error: JSON.parse requires at least one
parameter

(midori:16502): GLib-CRITICAL **: g_key_file_load_from_data: assertion `data !=
NULL' failed

** (midori:16502): WARNING **: Недоступен корневой сертификат. SSL сертификат
не может быть проверен.

(midori:16502): GLib-CRITICAL **: g_markup_escape_text: assertion `text !=
NULL' failed

(midori:16502): GLib-CRITICAL **: g_regex_replace_literal: assertion
`replacement != NULL' failed

(midori:16502): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16502): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16502): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16502): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

(midori:16502): GLib-CRITICAL **: g_regex_replace_eval: assertion `string !=
NULL' failed

** (midori:16502): CRITICAL **: void
webkit_web_frame_load_alternate_string(WebKitWebFrame*, const gchar*, const
gchar*, const gchar*): assertion `content' failed
Ошибка сегментирования
$ 

Some other (webkit-based) browsers also crash here; the following
(non-webkit-based) browsers don't crash:

firefox-5.0-5.0.1-alt0.M60P.1
kde4base-konqueror-4.6.5-alt1.M60P.1
------- Comment #1 From 2011-08-17 17:30:08 -------
У меня не упали :

 midori-0.3.6-alt2, chromium-browser-12.0.742.21-alt1.M60P.1.r84415,
skipstone-1.0.1-alt2, epiphany-2.30.6-alt2, arora-0.11.0-alt1

Мидори, впрочем, сама по себе запросто может упасть.