Bug 26253 - add armv7l to %arm
: add armv7l to %arm
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm-build)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-09-08 14:51 by
Modified: 2012-08-18 01:17 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-09-08 14:51:21
с некоторых пор (сейчас стоит qemu-user-binfmt_misc-0.14.0-alt4 ) uname -m в
qemu-arm стал выдавать "armv7l", что перестало устраивать postinstall-script в
glibc-kernelheaders (fix-asmdir.sh), который сравнивает текущий "ARCH=`uname
-m`" с содержимым %arm, который на данный момент равен
arm armeb armv3l armv4l armv4b armv5l armv5l armv5tel armv5tejl
в версии rpm-4.0.4-alt100.24

в результате скрипт промахивается и вместо ссылки
/usr/include/linux-default/include/asm -> asm-arm
создает ссылку
/usr/include/linux-default/include/asm -> asm-armv7l
что ведет к 
/usr/include/linux-default/include/asm/: No such file or directory
и при сборке пакетов к 
In file included ...
/usr/include/bits/sigcontext.h:28:29: fatal error: asm/sigcontext.h: No such
file or directory

(т.е. при сборке разных пакетов всё, что должно браться из asm/* обламывается).

собрать что-либо (использующее asm/*) в hasher с hsh --with-qemu=arm
--target=arm и на основе репозитория SisyphusARM становится невозможно.

Зафиксил, добавив в скрипт fix-asmdir.sh в явном виде armv7l в строку ARM="".

Предлагаю добавить это и в %arm, но вообще это ненадолго.. до следующего
изменения в uname -m в qemu-arm.
Вероятно, можно исправить саму логику скрипта
"если в строке не нашли знакомого-создадим прямтак"..
------- Comment #1 From 2012-08-18 01:17:02 -------
rpm-4.0.4-alt100.54 -> sisyphus:

* Fri Aug 17 2012 Dmitry V. Levin <ldv@altlinux> 4.0.4-alt100.54
- Added armh arch support (by Sergey Bolshakov; closes: #26253).
- GROUPS: added Graphical desktop/MATE (by Igor Vlasenko; closes: #27626).
- %patch: added -F/-d options and appropriate macros for better
  spec file compatibility (by Igor Vlasenko; closes: #27627).
- %configure: update config.sub and config.guess right before configure.
- debugedit: backported DWARF-4 support from rpm.org.