Bug 26320 - опять неправильно оптимизирует
: опять неправильно оптимизирует
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm-utils)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2011-09-17 01:33 by
Modified: 2014-01-17 18:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-09-17 01:33:53
$ /usr/share/buildreqs/optimize_package_list <<< perl-HTML-Tree
tsort: -: input contains a loop:
tsort: perl-HTML-Format
tsort: perl-HTML-Tree
$
------- Comment #1 From 2011-10-30 13:32:53 -------
$ /usr/share/buildreqs/optimize_package_list <<< perl-HTML-Tree
perl-HTML-Tree
$ rpm -q rpm-utils
rpm-utils-0.9.15-alt1

Насколько понимаю, код по поводу этой баги не трогался.
------- Comment #2 From 2011-10-30 13:36:40 -------
Для того, чтобы воспроизвести эту ошибку, нужно установить perl-HTML-Tree.
------- Comment #3 From 2014-01-17 18:13:42 -------
rpm-utils-0.9.18-alt1 -> sisyphus:

* Fri Jan 17 2014 Dmitry V. Levin <ldv@altlinux> 0.9.18-alt1
- optimize_package_list: fixed misoptimization (closes: #26320).