Bug 26348 - не работает apt
: не работает apt
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: x86_64 Linux
: P3 blocker
Assigned To:
:
: http://www.altlinux.org/Changes/apt
:
:
:
  Show dependency tree
 
Reported: 2011-09-22 09:05 by
Modified: 2011-10-30 18:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-09-22 09:05:38
система, установленная с KDesktop6 (beta) и затем обновлённая до Сизифа.

начиная с 15 сентября, попытка установить, удалить любой пакет или сделать
dist-upgrade, не удаётся:

# apt-get update

Получено 16,4MB за 5s (2861kB/s).
Чтение списков пакетов... Ошибка!
E: Dynamic MMap ran out of room
E: При обработке libwebkitgtk2 (NewVersion1) возникла ошибка
E: Ошибка с MergeList /var/lib/rpm/Packages
E: Невозможно прочитать список пакетов или файл статуса.

После добавления в /etc/apt/apt.conf 

APT::Cache-Limit "16777216";

имеем
Чтение списков пакетов... Ошибка!
*** glibc has detected an error in apt-get: double free or corruption (out):
0x00007f46e13f0010 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x71c66)[0x7f46e3db9c66]
/lib64/libc.so.6(cfree+0x70)[0x7f46e3dbeb10]
/lib64/libdb-4.7.so(+0xb4d86)[0x7f46e2085d86]
/lib64/libdb-4.7.so(+0xa8805)[0x7f46e2079805]
/lib64/libdb-4.7.so(+0xa8f31)[0x7f46e2079f31]
/lib64/libdb-4.7.so(+0xbe33d)[0x7f46e208f33d]
/usr/lib64/librpmdb-4.0.4.so(+0x6bb6)[0x7f46e3485bb6]
/usr/lib64/librpmdb-4.0.4.so(rpmdbClose+0x55)[0x7f46e3492655]
/usr/lib64/libapt-pkg-libc6.9-6.so.2(_ZN12RPMDBHandlerD1Ev+0x33)[0x7f46e46127e3]
/usr/lib64/libapt-pkg-libc6.9-6.so.2(_ZN12RPMDBHandlerD0Ev+0x9)[0x7f46e46128f9]
/usr/lib64/libapt-pkg-libc6.9-6.so.2(_ZN9rpmSystem6UnLockEb+0x50)[0x7f46e4637e00]
apt-get[0x40b757]
/usr/lib64/libapt-pkg-libc6.9-6.so.2(_ZN11CommandLine11DispatchArgEPNS_8DispatchEb+0x66)[0x7f46e46003d6]
apt-get[0x414475]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7f46e3d66c5d]
apt-get[0x406fe9]


После изменения на совсем уж неприличный 
APT::Cache-Limit "500000000";
имеем:

# apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Ошибка
Следующие пакеты имеют неудовлетворенные зависимости:
  libqscintilla2-6-qt4: Вытесняет: libqscintilla2-5-qt4
E: Ошибка. Процедура pkgProblemResolver::Resolve вызвала остановку. Это может
быть вызвано сохраняемыми пакетами.
------- Comment #1 From 2011-09-22 14:12:09 -------
(In reply to comment #0)
> После изменения на совсем уж неприличный 
> APT::Cache-Limit "500000000";
> имеем:

Начиная с apt-0.5.15lorg2-alt34, значение по умолчанию у APT::Cache-Limit равно
50331648.
------- Comment #2 From 2011-10-30 18:24:17 -------
Этому изменению уже несколько больше IIRC...