Bug 26673 - Блокирует сборку
: Блокирует сборку
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libslang)
: unstable
: all Linux
: P3 critical
Assigned To:
:
:
:
: 26578
:
  Show dependency tree
 
Reported: 2011-12-05 23:40 by
Modified: 2012-09-26 10:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-12-05 23:40:36
i586: kde4multimedia-dragonplayer-debuginfo=4.7.4-alt1 preinstall failed:
file /usr/lib/debug/usr/lib/libslang.so.debug conflicts between attempted
installs of libslang2-debuginfo-2.2.3-alt2 and libslang-debuginfo-1.4.9-alt1.3
hsh-install: Packages installation failed.

http://git.altlinux.org/tasks/59625/logs/events.1.1.log

P.S.
Я вроде уже вешал подобную багу, но не смог найти :-(
------- Comment #1 From 2011-12-06 01:15:49 -------
Это фича, а не бага: не надо (неявно) собирать софт сразу с двумя slang'ами:
$ grep libslang
/tasks/59625/install/kde4multimedia-dragonplayer/i586/chroot_install 
libslang    1.4.9-alt1.3    i586    slang-1.4.9-alt1.3.src.rpm   
4b38b30bcd7f9e6624ed3ea72574fb749ad26893
libslang2    2.2.3-alt2    i586    slang2-2.2.3-alt2.src.rpm   
9d2b44e57062338af763bf93e6c7de993c816cc7

Очень хорошо, что install check выявляет такие ошибки.
------- Comment #2 From 2011-12-06 12:34:48 -------
Подобное наблюдалось и при простом dist-upgrade, когда я последний раз делил
poppler.
------- Comment #3 From 2011-12-06 12:37:57 -------
1. Я не собирал ничего с двумя slang'ами.
2. Кто допустил ошибку, из-за которой сборка не прошла?

P.S.
Перевесьте на пакет, в котором ошибка.
------- Comment #4 From 2011-12-06 12:48:13 -------
Вообще, я думаю, что libslang2-debuginfo и libslang-debuginfo должны явно
конфликтовать. Наверняка эти конфликты прописаны в пакетах libslang2-devel и
libslang-devel.

P.S.
Может, если файл находиться в пакете xxx-devel, то и файл отладки должен
располагаться в соответствующем пакете -- xxx-devel-debuginfo ?
------- Comment #5 From 2011-12-06 13:05:59 -------
Баги 26578 и 26671 из этой же оперы
------- Comment #6 From 2011-12-06 14:41:36 -------
Можно узнать, в чем ошибка мантейнера пакета libslang ?
------- Comment #7 From 2011-12-06 19:26:59 -------
После починки 26578 будет срочно необходимо пересобрать libslang или libslang2,
т.к. у меня task 59625 завис
------- Comment #8 From 2011-12-07 06:33:00 -------
(In reply to comment #6)
> Можно узнать, в чем ошибка мантейнера пакета libslang ?

Пакет slang1 не нужен.
Пакет slang2 нужно привести в порядок.
------- Comment #9 From 2011-12-07 14:41:15 -------
Удалить slang1 недолго, тогда libslang2 пока
------- Comment #10 From 2011-12-08 00:06:25 -------
(In reply to comment #1)
> Это фича, а не бага: [...]
> Очень хорошо, что install check выявляет такие ошибки.
Это бага в том смысле, что конфликт должен был быть прописан ещё между -devel
(как и обсуждалось в bug #15151).
------- Comment #11 From 2011-12-08 20:28:40 -------
(В ответ на комментарий №10)
> конфликт должен был быть прописан ещё между -devel
Это никак не влияет на результат
------- Comment #12 From 2012-09-26 05:12:41 -------
libslang is no more.