Bug 2678 - Не переключает темы с картинками
: Не переключает темы с картинками
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/gtk-theme-switch)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-06-18 12:57 by
Modified: 2006-02-17 16:36 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-06-18 12:57:39
Не переключает темы GTK 1.* и GTK 2.* приложений
Пример темы
<a href="http://themes.freshmeat.net/redir/xliquid_gtk/31519/url_tgz/xliquid_gtk-stable-1.0.3.tar.gz">http://themes.freshmeat.net/redir/xliquid_gtk/31519/url_tgz/xliquid_gtk-stable-1.0.3.tar.gz</a>

---

---
Порядок действий:
gtk-theme-swith - из поставки ALM 2.2 - при запуске ругался 
==
Gtk-WARNING **: Unable to locate loadable module in module_path: \&quot;libpixmap.so\&quot;,
==
Запускаем strace gtk-theme-swith - видим.
==
open(\&quot;/usr/lib/gtk/themes/engines/libpixmap.so\&quot;, O_RDONLY) = -1 ENOENT (No such file or directory)
==
Ладно думаю - может подойдет ему libpixmap.so от GTK2 
кидаю указанную либу в /usr/lib/gtk/themes/engines/
что и следовало ожидать - ФИГА ВАМ
==
Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (major mismatch)
==

В файле
/usr/share/themes/XLiquid_GTK-1.0.1/gtk/gtkrc
была изменена и раскоментирована строчка
pixmap_path \&quot;/usr/share/themes/XLiquid_GTK-1.0.1/gtk/\&quot;
Ну ничего это не дало.
При установке данной темы меняются только цвета - а картинки упорно не показываются

Была установлена версия gtk-theme-swith для GTK2 - с сайта разработчика - она смогла переключать лишь темы для GTK2 приложений.

По совету был установлен gtk-engines из Master 2.0 - лишь тогда gtk-theme-swith заработал для GTK 1 приложений
------- Comment #1 From 2003-06-18 13:39:06 -------
Provides: gtk-engines (= 2.2.0-alt2.4)
Obsoletes: gtk-engines

Вот в этом-то и проблема.  Плюс пока мы декларируем поддержку тем gtk1 -- gtk-engines _должны_ быть (и сосуществовать с GTK2-версией, что у них вполне получается).
------- Comment #2 From 2003-06-18 13:39:06 -------
Provides: gtk-engines (= 2.2.0-alt2.4)
Obsoletes: gtk-engines

Вот в этом-то и проблема.  Плюс пока мы декларируем поддержку тем gtk1 -- gtk-engines _должны_ быть (и сосуществовать с GTK2-версией, что у них вполне получается).
------- Comment #3 From 2004-05-24 15:40:07 -------
to maintainer 
------- Comment #4 From 2004-06-04 17:59:06 -------
Стас, эта проблема относилась к упаковке gtk-engines.

Не знаю, актуальна ли она сейчас -- можно просто выбросить пакет в orphaned.