Bug 26855 - mysql-workbench-gpl явно требует gnome-keyring
: mysql-workbench-gpl явно требует gnome-keyring
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/mysql-workbench-community)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-01-25 13:06 by
Modified: 2015-10-13 08:20 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-01-25 13:06:03
В пакете mysql-workbench-gpl вручную (Requires:) прописана зависимость на
gnome-keyring.
Нельзя ли его убрать?
------- Comment #1 From 2012-01-26 10:20:36 -------
Вопрос, наверное, к Евгению. Эта зависимость из его коммита
bb5ad27f9899241d0027384dc2b4fbb35377adcd

Кстати, новые версии есть уже. Помнится, следующая после 5.2.33, которая сейчас
в Сизифе, хотела Python 2.7. Сейчас это условие в Сизифе выполняется.
------- Comment #2 From 2012-10-27 13:34:17 -------
Евгений, так что с зависимостью ? Нужна, или нет ?
------- Comment #3 From 2015-09-18 22:40:36 -------
Смотрю на версию 6.3.4. Она, вообще, его при сборке проверяет:

-- checking for module 'gnome-keyring-1'
--   package 'gnome-keyring-1' not found
-- checking for module 'gnome-keyring'
--   package 'gnome-keyring' not found

Пока, правда, не знаю, на сколько оно необходимо.
------- Comment #4 From 2015-10-13 08:20:50 -------
Наверное, notabug. В врапере /usr/bin/mysql-workbench, в 6.3.4, есть такое
комментарий:

# Uncomment the following line if you're having trouble with gnome-keyring
lockups.
# This will cause passwords to be stored only temporarily for the session.
#WB_NO_GNOME_KEYRING=1