Bug 26876 - apt-get dist-upgrade удаляет пакеты, отвечающие за графику
: apt-get dist-upgrade удаляет пакеты, отвечающие за графику
Status: NEW
: Branch p6
(All bugs in Branch p6/apt)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-01-30 12:13 by
Modified: 2012-01-30 15:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-01-30 12:13:11
Поставил в init.d третий уровень загрузки по умолчанию.
Сделал apt-get dist-upgrade.
Менеджер пакетов снёс kde, gnome и прочие оболочки, оставив после своей работы
лишь неработающий X-сервер.
Собственно, так и должно быть или это ошибка?
------- Comment #1 From 2012-01-30 12:53:26 -------
А с чего он должен их сносить? Что делали?
------- Comment #2 From 2012-01-30 13:02:44 -------
>А с чего он должен их сносить?
Не знаю же. Если бы знал, то не создавал бы тикет.
>Что делали?
Последовательность действий описана в тикете. Повторюсь.
1. Устанавливаем в inittab initdefault на третий уровень.
2. Выполняем apt-get dist-upgrade.
3. Менеджер пакетов сносит всю графику.
------- Comment #3 From 2012-01-30 13:51:59 -------
Не воспроизводится, так как от содержимого inittab зависимости apt-get не
зависят. Приведите, пожалуйста, вывод

 apt-get dist-upgrade -oDebug::pkgProblemResolver=1
------- Comment #4 From 2012-01-30 14:09:30 -------
Да, действительно, вышла ошибка.
Проблема была в репозитории. Что-то с зависимостями.
------- Comment #5 From 2012-01-30 14:36:03 -------
(В ответ на комментарий №4)
> Да, действительно, вышла ошибка.
> Проблема была в репозитории. Что-то с зависимостями.
Скорее всего, что-то не так указали (локальная проблема конфигурации). Вывод
указанной мною должен был показать причину проблемы.