Bug 27023 - Добавить поддержку Canon i-4410 в sane
: Добавить поддержку Canon i-4410 в sane
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/sane)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 23155 26944
  Show dependency tree
 
Reported: 2012-03-02 12:01 by
Modified: 2012-03-15 00:07 (History)


Attachments
http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20120109/d418c75b/attachment.bin (3.50 KB, patch)
2012-03-02 12:51, Michael Shigorin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-03-02 12:01:32
Появился патч для поддержки Canon i-4410 

http://lists.alioth.debian.org/pipermail/sane-devel/2012-February/029581.ht
------- Comment #1 From 2012-03-02 12:05:05 -------
(В ответ на комментарий №0)
> Появился патч для поддержки Canon i-4410 
> 
> http://lists.alioth.debian.org/pipermail/sane-devel/2012-February/029581.ht

Потерял последние символы в ссылке, правильная ссылка 

 http://lists.alioth.debian.org/pipermail/sane-devel/2012-February/029581.html
------- Comment #2 From 2012-03-02 12:51:27 -------
Created an attachment (id=5343) [details]
http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20120109/d418c75b/attachment.bin

Хвост про mkinstalldirs к сизифному пакету не прикладывается; убрал,
собирается:
http://git.altlinux.org/people/mike/packages/?p=sane.git;a=shortlog;h=refs/heads/master
------- Comment #3 From 2012-03-06 01:49:10 -------
Просьба проверить пакеты из http://git.altlinux.org/tasks/65789/ (если нужна
тестовая сборка для бранча -- уточните его, пожалуйста).
------- Comment #4 From 2012-03-07 13:09:09 -------
Олег, получилось проверить?
------- Comment #5 From 2012-03-09 03:11:18 -------
sane-1.0.22-alt3 -> sisyphus:

* Fri Mar 02 2012 Michael Shigorin <mike@altlinux> 1.0.22-alt3
- added Canon MF4410 support patch (ALT bug #27023)
------- Comment #6 From 2012-03-12 17:41:56 -------
При проверке пакетов sane-1.0.22-alt3 из Сизифа на Симпли 6.0  (i586)
Сканер не определяется.

Возможно ли собрать для проверки эти пакеты под p6 ?
------- Comment #7 From 2012-03-12 17:48:18 -------
(В ответ на комментарий №6)
> При проверке пакетов sane-1.0.22-alt3 из Сизифа на Симпли 6.0  (i586)
> Сканер не определяется.
> 
> Возможно ли собрать для проверки эти пакеты под p6 ?
В p6 уже сейчас та же версия.
------- Comment #8 From 2012-03-13 18:04:16 -------
Пробежался по 

http://git.altlinux.org/people/mike/packages/?p=sane.git;a=shortlog;h=refs/heads/master

И не обнаружил там основных изменений в файле backend/pixma_imageclass.c
которые отвечают за работу с MF-4410 , по ссылке ниже вроде есть описание что
нужно менять. Может не тот патч приложился ?

http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20120109/d418c75b/attachment.bin
------- Comment #9 From 2012-03-14 11:22:08 -------
Проверил на дистре KDE 6.0 р6 , сканер работает.
Следовательно с самими пакетами все в порядке, патчи приложились как надо.
------- Comment #10 From 2012-03-15 00:07:06 -------
(In reply to comment #9)
> Проверил на дистре KDE 6.0 р6 , сканер работает.
Спасибо!

> Следовательно с самими пакетами все в порядке, патчи приложились как надо.
Патч добавлен этим коммитом:
http://git.altlinux.org/people/mike/packages/?p=sane.git;a=commitdiff;h=b9bd0da3f8a42b9687d07991c3b6fb4716cd9fa4
а приложен -- этим:
http://git.altlinux.org/people/mike/packages/?p=sane.git;a=commitdiff;h=808e7db00039b1174d37c50b7c01a91b8c4250a7
(решил оставить его в явном виде)