Bug 27081 - Устанавливает не то, что просят, а наиболее свежий пакет
: Устанавливает не то, что просят, а наиболее свежий пакет
Status: NEW
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-03-15 17:27 by
Modified: 2012-03-16 14:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-03-15 17:27:12
При попытке установить rpm-пакет не из репозитария и при наличии в кэше более
нового пакета, ставит более новый пакет из кэша.

Далее копия из форума:
http://forum.altlinux.org/index.php/topic,19259.msg172405.html#msg172405

# apt-get install libxforms-1.0-alt2.i586.rpm
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting libxforms for 'libxforms-1.0-alt2.i586.rpm'
The following NEW packages will be installed:
  libxforms
0 upgraded, 1 newly installed, 0 removed and 2 not upgraded.
Need to get 0B/395kB of archives.
After unpacking 1063kB of additional disk space will be used.
Committing changes...
Preparing...                
############################################################################################
[100%]
1: libxforms                
############################################################################################
[100%]
Running /usr/lib/rpm/posttrans-filetriggers
Done.

# rpm -qa|grep libxforms
libxforms-1.0.93-alt1

Установленным оказался более новый пакет.
------- Comment #1 From 2012-03-15 17:37:47 -------
Selecting libxforms for 'libxforms-1.0-alt2.i586.rpm'


А если сделать apt-get install ./libxforms-1.0-alt2.i586.rpm или apt-get
install /full/path/to/libxforms-1.0-alt2.i586.rpm ?
------- Comment #2 From 2012-03-15 18:14:33 -------
То же самое. Да и "ARHAN" с форума, судя по тому, что писал, изначально так
делал.
------- Comment #3 From 2012-03-15 20:30:51 -------
Я в таких случаях так делаю:
apt-get install libxforms-1.0-alt2.i586.rpm libxforms=1.0-alt2
Наверное это хак :)