Bug 27121 - Бьется изображение
: Бьется изображение
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libcairo)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-03-26 08:31 by
Modified: 2012-09-24 05:06 (History)


Attachments
Лог обновления пакетов (3.00 KB, text/x-log)
2012-03-26 08:31, Evgenii Terechkov
no flags Details
Скриншот проблемы (16.56 KB, image/png)
2012-03-26 08:31, Evgenii Terechkov
no flags Details
Лог запуска иксов. (35.33 KB, text/x-log)
2012-03-26 08:33, Evgenii Terechkov
no flags Details
Вывод lspci (2.71 KB, text/plain)
2012-03-26 08:34, Evgenii Terechkov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-03-26 08:31:05
Created an attachment (id=5415) [details]
Лог обновления пакетов

После обновления (лог прилагаю) начала проявляться проблема: при движении
указателя мыши поверх строки вкладок Chromium текст на них "бьётся" (см.
скриншот). Если снова навести указатель на проблемную вкладу, изображение
восстанавливается. Посмотрю, возможно где-то ещё проявляется.
------- Comment #1 From 2012-03-26 08:31:38 -------
Created an attachment (id=5416) [details]
Скриншот проблемы
------- Comment #2 From 2012-03-26 08:33:33 -------
Created an attachment (id=5417) [details]
Лог запуска иксов.

Лог запуска иксов прилагаю. Как я понял, автоматически выбирается драйвер
nouveau.
------- Comment #3 From 2012-03-26 08:34:19 -------
Created an attachment (id=5418) [details]
Вывод lspci

Дополнительные данные приведу, при необходимости.
------- Comment #4 From 2012-03-26 09:53:28 -------
это проблемы nouveau с cairo-1.12.0, у меня такое с firefox наблюдается
------- Comment #5 From 2012-03-26 10:12:06 -------
Похоже. У меня наблюдается и в awesome, он работает через
libcairo/libpangocairo.
------- Comment #6 From 2012-03-26 10:17:04 -------
проблема локализована - egl backend
если его отключить, отвалится wayland
------- Comment #7 From 2012-03-26 10:30:07 -------
oops... не помогает
------- Comment #8 From 2012-03-26 14:41:37 -------
firefox+cairo-1.12.0+radeon, эффект подтверждаю. При подсовывании LD_PRELOAD
cairo из p6 эффект пропадает
------- Comment #9 From 2012-03-28 13:19:48 -------
Еще раз подтверждаю эффект на radeon 6670.
------- Comment #10 From 2012-04-04 00:05:28 -------
(В ответ на комментарий №4)
> это проблемы nouveau с cairo-1.12.0, у меня такое с firefox наблюдается

Похоже Impress в "офисе" также не показывает презентации - экран замирает и
все. Стесняюсь спросить, где взять предпоследнюю версию cairo?
------- Comment #11 From 2012-04-04 02:25:52 -------
См. http://www.altlinux.org/Sisyphus_archive и дальше по libcairo =>
ftp://ftp.altlinux.org/pub/distributions/archive/Sisyphus/2012/02/16/files/
------- Comment #12 From 2012-04-06 10:09:22 -------
К сведению.
Вот тут:
https://bugs.archlinux.org/task/29218?project=1&openedfrom=-1+week
утверждают, что в их сборке исправлено. Также приводится срочный фикс через
параметр в xorg.conf.
Единственный патч тут:
http://projects.archlinux.org/svntogit/packages.git/tree/trunk/cairo-1.10.0-buggy_gradients.patch?h=packages/cairo
------- Comment #13 From 2012-04-06 10:17:57 -------
Вот еще, к сведению: https://bugs.freedesktop.org/show_bug.cgi?id=47266
------- Comment #14 From 2012-04-12 05:12:54 -------
Судя по
http://packages.qa.debian.org/x/xserver-xorg-video-intel/news/20120405T190304Z.html
, исправление для драйвера intel тут:
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=fde8a010b3d9406c2f65ee99978360a6ca54e006

Возможно, корректнее разнести багу по драйверам, хотя проще следить за ней в
одном месте.
------- Comment #15 From 2012-04-12 16:04:17 -------
Помните, когда ещё /etc/X11/xorg.conf использовался, в нём всё время
автоматически генерировался кусочек вида Option "omit xfree86-dga"?

В общем, с xorg.conf вот такого вида (от начала до конца):

Section "Module"
        SubSection      "extmod"
                Option "omit xfree86-dga"
        EndSubSection
EndSection

Пока проблем не наблюдается.

Сизиф, драйвер xorg-drv-radeon-6.14.4-alt1,
03:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV610
video device [Radeon HD 2400 PRO] (prog-if 00 [VGA controller])
        Subsystem: PC Partner Limited Sapphire HD 2400 PRO video device
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at fdce0000 (64-bit, non-prefetchable) [size=64K]
        I/O ports at bc00 [size=256]
        Expansion ROM at fdcc0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: radeon
------- Comment #16 From 2012-04-12 16:24:25 -------
Ложная тревога. По прошествии времени опять заглючило.
------- Comment #17 From 2012-04-30 22:58:38 -------
Судя по https://bugs.freedesktop.org/show_bug.cgi?id=47266 и
git.freedesktop.org/xorg/driver/ :
-- исправлено в только что вышедших  xf86-video-intel-2.19.0 
-- исправлено в git драйвера ati
Было бы здорово собрать хотя бы драйверы intel
C nouveau и nvidia все по-прежнему плохо.
------- Comment #18 From 2012-05-01 12:42:41 -------
(В ответ на комментарий №17)

> Было бы здорово собрать хотя бы драйверы intel

Спасибо!
У кого intel, -- прошу тестировать.
------- Comment #19 From 2012-05-06 00:08:44 -------
(В ответ на комментарий №18)
> (В ответ на комментарий №17)
> 
> > Было бы здорово собрать хотя бы драйверы intel
> 
> Спасибо!
> У кого intel, -- прошу тестировать.

У меня intel (на Samsung N100, нетбук). Перезаружусь, погоняю и отпишусь.
------- Comment #20 From 2012-05-06 15:25:25 -------
(В ответ на комментарий №19)
> (В ответ на комментарий №18)
> > (В ответ на комментарий №17)
> > 
> > > Было бы здорово собрать хотя бы драйверы intel
> > 
> > Спасибо!
> > У кого intel, -- прошу тестировать.
> 
> У меня intel (на Samsung N100, нетбук). Перезаружусь, погоняю и отпишусь.

Intel. Второй день -- всё чисто.

$ cat /var/log/Xorg.0.log | grep -A5 -B5 2.19.0
[    29.440]     ABI class: X.Org Server Extension, version 6.0
[    29.440] (II) Loading extension DRI2
[    29.440] (II) LoadModule: "intel"
[    29.441] (II) Loading /usr/lib/X11/modules/drivers/intel_drv.so
[    29.488] (II) Module intel: vendor="X.Org Foundation"
[    29.488]     compiled for 1.12.1, module version = 2.19.0
[    29.489]     Module class: X.Org Video Driver
[    29.489]     ABI class: X.Org Video Driver, version 12.0
[    29.489] (II) LoadModule: "fbdev"
[    29.489] (II) Loading /usr/lib/X11/modules/drivers/fbdev_drv.so
[    29.521] (II) Module fbdev: vendor="X.Org Foundation"
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated
Graphics Controller
$ rpm -qa | grep xorg | grep intel
xorg-drv-intel-2.19.0-alt1
xorg-dri-intel-8.0.2-alt1
$ uptime 
 14:24:02 up 2 days, 23:55, 12 users,  load average: 2.74, 1.87, 1.50
$
------- Comment #21 From 2012-05-06 20:38:41 -------
(В ответ на комментарий №18)
> (В ответ на комментарий №17)
> 
> > Было бы здорово собрать хотя бы драйверы intel
> 
> Спасибо!
> У кого intel, -- прошу тестировать.

У меня работает. Все ок. Nvidia теперь бы починить...
------- Comment #22 From 2012-05-06 20:48:48 -------
Временный рецпет от shaba@ для radeon:
http://lists.altlinux.org/pipermail/sisyphus/2012-May/357392.html
Можно попробовать и для других проблемных драйверов, пока их не починили.
------- Comment #23 From 2012-09-23 01:33:25 -------
На текущем Sisyphus проблему не наблюдаю. Спасибо shrek@ и апстриму.
Закрываем?
------- Comment #24 From 2012-09-23 02:14:25 -------
Обождите, на следующей неделе проверю (машина с nvidia-картой на работе).
------- Comment #25 From 2012-09-24 05:05:50 -------
Действительно, не проявляется больше. Спасибо!