Bug 27175 - Падает после некоторого времени работы.
: Падает после некоторого времени работы.
Status: NEW
: Sisyphus
(All bugs in Sisyphus/qutim)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-04-06 11:54 by
Modified: 2013-01-20 12:06 (History)


Attachments
трасса qutim valgrind-ой. (229.20 KB, text/plain)
2012-04-06 11:56, Горев Андрей
no flags Details
ldd по библиотекам плагинов. (247.03 KB, text/plain)
2012-04-20 08:35, Горев Андрей
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-04-06 11:54:38
Судя по тому,что нашёл из-за библиотек QT4. Пожрав память, грохается.
   Трасса valgrind-ой прилагается.
------- Comment #1 From 2012-04-06 11:56:40 -------
Created an attachment (id=5439) [details]
трасса qutim valgrind-ой.
------- Comment #2 From 2012-04-07 00:23:05 -------
А через сколько времени примерно он падает?
------- Comment #3 From 2012-04-15 23:34:41 -------
Чёт не удаётся повторить ошибку. Отправил в Сизиф новую версию (0.3.1.0-alt1) -
попробуйте, может проблема исчезнет. Так же можно попробовать грохнуть
настройки (~/.config/qutim), может дело в нём.
------- Comment #4 From 2012-04-20 08:35:46 -------
Created an attachment (id=5448) [details]
ldd по библиотекам плагинов.

  Там libsimplecontactlist.so есть. Но почему-то не обнаруживается самим
qutim-ом.
------- Comment #5 From 2012-04-20 08:40:24 -------
А вот как выглядит, когда qutim пускаешь в окне. .config/qutim отсутсствует.

"Невозможно загрузить библиотеку
/usr/lib/qutim/plugins/liboldcontactdelegate.so: (libsimplecontactlist.so:
невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)" 
"Невозможно загрузить библиотеку
/usr/lib/qutim/plugins/libplaincontactsmodel.so: (libsimplecontactlist.so:
невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)" 
"Невозможно загрузить библиотеку
/usr/lib/qutim/plugins/libseparatedcontactsmodel.so: (libsimplecontactlist.so:
невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)" 
"Невозможно загрузить библиотеку
/usr/lib/qutim/plugins/libsimplecontactdelegate.so: (libsimplecontactlist.so:
невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)" 

   Файл на деле есть:

/usr/lib/qutim/plugins/libsimplecontactlist.so: ELF 32-bit LSB shared object,
Intel 80386, version 1 (SYSV), dynamically linked, stripped
------- Comment #6 From 2012-04-20 11:05:07 -------
У меня точно также ругается при запуске из консоли, но при этом всё работает и
не падает даже через полтора часа. А какие конкретно пакеты кутима стоят?
------- Comment #7 From 2012-04-24 11:43:35 -------
        Стоит qutim-full в составе:
libqutim-0.3.1.0-alt1
libqutim-adiumwebview-0.3.1.0-alt1
libqutim-devel-0.3.1.0-alt1
qutim-0.3.1.0-alt1
qutim-docs-0.3.1.0-alt1
qutim-full-0.2.80.1-alt2.git20120324
qutim-lang-bg-0.3.1.0-alt1
qutim-lang-cz-0.3.1.0-alt1
qutim-lang-de-0.3.1.0-alt1
qutim-lang-en-0.3.1.0-alt1
qutim-lang-ru-0.3.1.0-alt1
qutim-lang-uk-0.3.1.0-alt1
qutim-plugin-adiumwebview-0.3.1.0-alt1
qutim-plugin-aescrypto-0.3.1.0-alt1
qutim-plugin-antiboss-0.3.1.0-alt1
qutim-plugin-antispam-0.3.1.0-alt1
qutim-plugin-aspeller-0.3.1.0-alt1
qutim-plugin-bearermanager-0.3.1.0-alt1
qutim-plugin-birthdayreminder-0.3.1.0-alt1
qutim-plugin-clconf-0.3.1.0-alt1
qutim-plugin-dbusapi-0.3.1.0-alt1
qutim-plugin-dbusnotifications-0.3.1.0-alt1
qutim-plugin-emoedit-0.3.1.0-alt1
qutim-plugin-floaties-0.3.1.0-alt1
qutim-plugin-highlighter-0.3.1.0-alt1
qutim-plugin-histman-0.3.1.0-alt1
qutim-plugin-hunspeller-0.3.1.0-alt1
qutim-plugin-kdeintegration-0.3.1.0-alt1
qutim-plugin-kineticpopups-0.3.1.0-alt1
qutim-plugin-logger-0.3.1.0-alt1
qutim-plugin-massmessaging-0.3.1.0-alt1
qutim-plugin-multimediabackend-0.3.1.0-alt1
qutim-plugin-nowplaying-0.3.1.0-alt1
qutim-plugin-olddelegate-0.3.1.0-alt1
qutim-plugin-phononsound-0.3.1.0-alt1
qutim-plugin-plugman-0.3.1.0-alt1
qutim-plugin-qmlchat-0.3.1.0-alt1
qutim-plugin-qrcicons-0.3.1.0-alt1
qutim-plugin-scriptapi-0.3.1.0-alt1
qutim-plugin-sdlsound-0.3.1.0-alt1
qutim-plugin-unreadmessageskeeper-0.3.1.0-alt1
qutim-plugin-urlpreview-0.3.1.0-alt1
qutim-plugin-weather-0.3.1.0-alt1
qutim-plugin-yandexnarod-0.3.1.0-alt1
qutim-protocol-astral-0.3.1.0-alt1
qutim-protocol-irc-0.3.1.0-alt1
qutim-protocol-jabber-0.3.1.0-alt1
qutim-protocol-mrim-0.3.1.0-alt1
qutim-protocol-oscar-0.3.1.0-alt1
qutim-protocol-quetzal-0.3.1.0-alt1
qutim-protocol-vkontakte-0.3.1.0-alt1
------- Comment #8 From 2013-01-20 12:06:15 -------
Вчера в Сизиф была отправлена новая версия с Git (0.3.1.0-alt1.git20130117). На
неё проблема сохраняется?