Bug 27314 - Не импортируется без numpy.lib.polynomial
: Не импортируется без numpy.lib.polynomial
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/python-module-numpy)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: http://lists.altlinux.org/pipermail/d...
:
:
: 27312
  Show dependency tree
 
Reported: 2012-05-09 16:45 by
Modified: 2012-05-16 17:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-05-09 16:45:33
>>> import numpy
Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
    File "/usr/lib64/python2.7/site-packages/numpy/__init__.py", line 137, in
<module>
      import add_newdocs
    File "/usr/lib64/python2.7/site-packages/numpy/add_newdocs.py", line 9, in
<module>
      from numpy.lib import add_newdoc
    File "/usr/lib64/python2.7/site-packages/numpy/lib/__init__.py", line 13,
in <module>
      from polynomial import *
ImportError: No module named polynomial

Доустановка python-module-numpy-addons нормализует ситуацию. После этого
'import numpy' работает. Получается, что часть python-modules-numpy-addons (та
которая 
 'python2.7(numpy.lib.polynomial)') нужна самому python-module-numpy. И,
наверное, не относится к -addons.
------- Comment #1 From 2012-05-10 10:36:23 -------
Сейчас готовится обновление NumPy, там это будет учтено.
------- Comment #2 From 2012-05-11 18:38:59 -------
python-module-numpy-2.0.0-alt4.git20120502 -> sisyphus:

* Fri May 11 2012 Eugeny A. Rostovtsev (REAL) <real at altlinux>
2.0.0-alt4.git20120502
- New snapshot
- Added modules for Python 3
- Moved numpy.lib.polynomial into main package (ALT #27314)