Bug 27798 - Выключить CONFIG_REGULATOR_DUMMY (отвалился кардридер)
: Выключить CONFIG_REGULATOR_DUMMY (отвалился кардридер)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-std-def)
: unstable
: all Linux
: P3 critical
Assigned To:
:
:
: regression
: 28358
: 27685
  Show dependency tree
 
Reported: 2012-10-04 08:21 by
Modified: 2013-02-13 20:48 (History)


Attachments
вывод lspci -v (9.29 KB, application/octet-stream)
2012-10-18 20:49, Dmitriy Khanzhin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-10-04 08:21:18
После обновления до 3.6.0-un-def-alt1 обнаружил, что на ноутбуке (Toshiba
Satellite A300 149) не работает кардридер


0a:01.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev
02) (prog-if 01)
    Subsystem: Toshiba America Info Systems Satellite P305D-S8995E
    Flags: slow devsel, IRQ 16
    Memory at f0402800 (32-bit, non-prefetchable) [size=256]
    Capabilities: [a0] Power Management version 2

0a:01.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller
(rev 01)
    Subsystem: Toshiba America Info Systems Satellite P305D-S8995E
    Flags: slow devsel, IRQ 5
    Memory at f0401000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: [a0] Power Management version 2

Просто молча отвалился, не реагирует на вставку карточки никак. В
3.5.4-un-def-alt1 работал без нареканий.

В логах нагрепалось при загрузке:

Oct  3 16:15:39 deimos kernel: [    5.840703] sdhci: Secure Digital Host
Controller Interface driver
Oct  3 16:15:39 deimos kernel: [    5.840707] sdhci: Copyright(c) Pierre Ossman
Oct  3 16:15:39 deimos kernel: [    5.841629] sdhci-pci 0000:0a:01.2: SDHCI
controller found [1217:7120] (rev 2)
Oct  3 16:15:39 deimos kernel: [    5.841694] 0000:0a:01.2 supply vmmc not
found, using dummy regulator
Oct  3 16:15:39 deimos kernel: [    5.841714] mmc0: Hardware doesn't report any
support voltages.

но это было и в предыдущих ядрах, где кардридер работал.
------- Comment #1 From 2012-10-18 20:49:34 -------
Created an attachment (id=5603) [details]
вывод lspci -v
------- Comment #2 From 2012-10-18 21:01:13 -------
Присоединяюсь. Нетбук DNS с Intel Atom N2800 на борту, вывод lspci -v опередил
комментарий.
С ядром 3.6.2-un-def-alt1 при втыкании SD-карты ничего не происходит.
Цитата из dmesg с этим ядром:
[    8.930314] sdhci: Secure Digital Host Controller Interface driver
[    8.930321] sdhci: Copyright(c) Pierre Ossman

[    9.317978] sdhci-pci 0000:03:00.1: SDHCI controller found [197b:2392] (rev
90)
[    9.318125] 0000:03:00.1 supply vmmc not found, using dummy regulator
[    9.318184] mmc0: Hardware doesn't report any support voltages.
[    9.318251] sdhci-pci 0000:03:00.2: SDHCI controller found [197b:2391] (rev
90)
[    9.318287] sdhci-pci 0000:03:00.2: Refusing to bind to secondary interface.

Цитата из dmesg с ядром 3.5.7-std-def-alt1:
[    8.930314] sdhci: Secure Digital Host Controller Interface driver
[    8.930321] sdhci: Copyright(c) Pierre Ossman

[    9.317978] sdhci-pci 0000:03:00.1: SDHCI controller found [197b:2392] (rev
90)
[    9.318125] 0000:03:00.1 supply vmmc not found, using dummy regulator
[    9.318184] mmc0: Hardware doesn't report any support voltages.
[    9.318251] sdhci-pci 0000:03:00.2: SDHCI controller found [197b:2391] (rev
90)
[    9.318287] sdhci-pci 0000:03:00.2: Refusing to bind to secondary interface.

Цитата из diff -u вывода lspci -v между ядрами std-def и un-def
--- lspci.std-def    2012-10-16 19:04:25.471892594 +0400
+++ lspci.un-def    2012-10-16 19:11:27.200170849 +0400
@@ -169,13 +170,12 @@

 03:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
(rev 90)
     Subsystem: CLEVO/KAPOK Computer Device 2100
-    Flags: bus master, fast devsel, latency 0, IRQ 19
+    Flags: fast devsel, IRQ 19
     Memory at 80014200 (32-bit, non-prefetchable) [size=256]
     Capabilities: [a4] Power Management version 3
     Capabilities: [80] Express Endpoint, MSI 00
     Capabilities: [94] MSI: Enable- Count=1/1 Maskable- 64bit-
     Capabilities: [100] Device Serial Number 27-26-d1-ff-ff-f5-90-00
-    Kernel driver in use: sdhci-pci

 03:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host
Controller (rev 90) (prog-if 01)
     Subsystem: CLEVO/KAPOK Computer Device 2100
------- Comment #3 From 2012-10-18 21:08:58 -------
Похожее на 3.5.6-std-pae-alt1 наблюдаю, не работает картридер. 
Oct 18 16:01:11 aris_dell kernel: usb 1-2: >new high-speed USB device number 3
using xhci_hcd
Oct 18 16:01:11 aris_dell kernel: usb 1-2: >Device not responding to set
address.
Oct 18 16:01:11 aris_dell kernel: usb 1-2: >Device not responding to set
address.
Oct 18 16:01:11 aris_dell kernel: usb 1-2: >device not accepting address 3,
error -71
Oct 18 16:01:11 aris_dell kernel: hub 1-0:1.0: >unable to enumerate USB device
on port 2

Рядом на 3.4.4-std-pae-alt1 без проблем.
------- Comment #4 From 2012-12-23 09:20:56 -------
Ping.

Я думаю, собака зарыта где-то в наших патчах, т.к. с текущими ядрами
изменений нет.
С un-def кардридер _не_ виден.
С std-def все нормально.

Да, кардридер PCI, не USB.
------- Comment #5 From 2013-01-19 16:11:28 -------
Сломали и в std-def!
Blocker'ом тогда будет.
------- Comment #6 From 2013-01-19 23:06:10 -------
*** Bug 28388 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2013-02-01 12:18:39 -------
* Tue Jan 29 2013 Anton V. Boyarshinov <boyarsh@altlinux> 1:3.7.5-alt1
- 3.7.5
- FANOTIFY and MMC_RICOH_MMC enabled
------- Comment #8 From 2013-02-02 05:47:29 -------
Все равно продолжает не работать.
Таки нашел то, ЧТО нужно искать.
Сделал CONFIG_REGULATOR_DUMMY is not set и взлетело.
Причем в 3.6.11-std-def оно было выключено.
Ссылка по теме
http://www.spinics.net/lists/linux-mmc/msg18259.html
------- Comment #9 From 2013-02-12 20:19:25 -------
Повторяю, между 3.6.11-std-def-alt1 и 3.7.7-std-def-alt1 был включен
CONFIG_REGULATOR_DUMMY:

--- config-3.6.11-std-def-alt1    2012-12-18 14:39:48.000000000 +0400
+++ config-3.7.7-std-def-alt1    2013-02-11 22:46:09.000000000 +0400
-# CONFIG_REGULATOR_DUMMY is not set
+CONFIG_REGULATOR_DUMMY=y

В результате кардридер, описанный выше, обслуживаемый модулем sdhci_pci
не работает, не реагирует на вставку карты.
Цитата из dmesg при этом:
[   10.217758] sdhci: Secure Digital Host Controller Interface driver
[   10.217766] sdhci: Copyright(c) Pierre Ossman
[   10.461062] sdhci-pci 0000:03:00.1: SDHCI controller found [197b:2392] (rev
90)
[   10.461145] 0000:03:00.1 supply vqmmc not found, using dummy regulator
[   10.461179] 0000:03:00.1 supply vmmc not found, using dummy regulator
[   10.461213] mmc0: Hardware doesn't report any support voltages.
[   10.461251] sdhci-pci 0000:03:00.2: SDHCI controller found [197b:2391] (rev
90)
[   10.461274] sdhci-pci 0000:03:00.2: Refusing to bind to secondary interface.

После возвращения в конфиг ядра
# CONFIG_REGULATOR_DUMMY is not set
и пересборки кардидер начал работать.
Цитата из dmesg при этом:
[    9.634453] sdhci: Secure Digital Host Controller Interface driver
[    9.634459] sdhci: Copyright(c) Pierre Ossman
[    9.866822] sdhci-pci 0000:03:00.1: SDHCI controller found [197b:2392] (rev
90)
[    9.866942] mmc0: no vqmmc regulator found
[    9.866952] mmc0: no vmmc regulator found
[    9.867099] Registered led device: mmc0::
[    9.926001] mmc0: SDHCI controller on PCI [0000:03:00.1] using DMA
[    9.926038] sdhci-pci 0000:03:00.2: SDHCI controller found [197b:2391] (rev
90)
[    9.926072] sdhci-pci 0000:03:00.2: Refusing to bind to secondary interface.
[   54.357144] mmc0: new SD card at address 1234
[   54.392560] mmcblk0: mmc0:1234 SA02G 1.81 GiB 
[   54.395114]  mmcblk0: p1

Противопоказаний к этому в интернетах я не обнаружил, а в Федоре
вообще отключены все CONFIG_REGULATOR.

Прошу вернуть в конфиг ядра
# CONFIG_REGULATOR_DUMMY is not set
------- Comment #10 From 2013-02-13 12:05:56 -------
kernel-image-std-def-1:3.7.7-alt1.1 -> sisyphus:

* Wed Feb 13 2013 Anton V. Boyarshinov <boyarsh@altlinux> 1:3.7.7-alt1.1
- REGULATOR_DUMMY disabled (closes #27798)
------- Comment #11 From 2013-02-13 20:48:42 -------
Спасибо.