Bug 27849 - Не работает монтирование cifs ресурсов с авторизацией kerberos
: Не работает монтирование cifs ресурсов с авторизацией kerberos
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/pam_mount)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
: 27909
: 27685
  Show dependency tree
 
Reported: 2012-10-15 16:41 by
Modified: 2012-11-14 14:40 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-10-15 16:41:26
После того, как cifs-utils перестали работать в suid режиме.
Соответственно возникли проблемы:
* монтирование из под пользователя невозможно по очевидным причинам
* монтрование из под root должно столкнуться с проблемой получения
пользовательского билета kerberos, так как получает его ядро при помощи
cifs-upcall и способа указать, билет какого пользователя следует брать, с ходу
не видно.
* pam-mount выполняет монтирование от имени пользователя, что невозможно для
текущей версии cifs-utils

Надо так или иначе распутать этот клубок.
------- Comment #1 From 2012-10-17 20:45:02 -------
(В ответ на комментарий №0)
>Надо так или иначе распутать этот клубок.

Может, стоит начать со сборки свежего cifs-utils (5.7 сейчас, кажется, или
хотябы 5.6)?
------- Comment #2 From 2012-10-18 15:30:28 -------
(В ответ на комментарий №1)
> (В ответ на комментарий №0)
> >Надо так или иначе распутать этот клубок.
> 
> Может, стоит начать со сборки свежего cifs-utils (5.7 сейчас, кажется, или
> хотябы 5.6)?

Распутыванию клубка это вряд ли поможет, но собрать актуальную версию обычно
бывает полезно.
------- Comment #3 From 2012-10-31 06:44:39 -------
(In reply to comment #1)
> (В ответ на комментарий №0)
> >Надо так или иначе распутать этот клубок.
> 
> Может, стоит начать со сборки свежего cifs-utils (5.7 сейчас, кажется, или
> хотябы 5.6)?

#27909
------- Comment #4 From 2012-10-31 13:39:30 -------
5.7 собрал: http://git.altlinux.org/tasks/archive/done/_81/83489/
------- Comment #5 From 2012-11-14 14:40:48 -------
installer-feature-network-shares-client-0.8-alt1
alterator-kdc-0.4-alt1