Bug 28006 - Conflicts between attempted installs of exim-common-4.76-alt2 and sendmail-common-1.7-alt3
: Conflicts between attempted installs of exim-common-4.76-alt2 and sendmail-co...
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/exim-common)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-11-19 18:54 by
Modified: 2013-03-20 01:05 (History)


Attachments
CVE-2012-5671.patch (1.78 KB, patch)
2013-03-05 09:48, Chess
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-11-19 18:54:06
apt-get install exim-light
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  exim-common exim-control libspf2 libsqlite3 libsrs_alt sendmail-common
The following NEW packages will be installed:
  exim-common exim-control exim-light libspf2 libsqlite3 libsrs_alt
sendmail-common
0 upgraded, 7 newly installed, 0 removed and 0 not upgraded.
Need to get 0B/1449kB of archives.
After unpacking 4483kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Committing changes...
Preparing...                                     
###################################################################################################
[100%]
file /usr/sbin/mailq conflicts between attempted installs of
exim-common-4.76-alt2 and sendmail-common-1.7-alt3
------- Comment #1 From 2012-11-19 19:18:41 -------
Надо убрать /usr/sbin/mailq из пакета exim-common, поскольку он уже есть в
sendmail-common >= 1.7-alt3.
------- Comment #2 From 2013-01-09 17:28:54 -------
(В ответ на комментарий №1)
> Надо убрать /usr/sbin/mailq из пакета exim-common, поскольку он уже есть в
> sendmail-common >= 1.7-alt3.

так что никто не пере соберет ее ?
------- Comment #3 From 2013-03-04 13:31:27 -------
По факту exim оказался бесхозным, я бы не рекомендовал его использовать.
Кажется, там ещё и дырка последняя не заткнута...
------- Comment #4 From 2013-03-04 17:45:58 -------
(В ответ на комментарий №3)
> По факту exim оказался бесхозным, я бы не рекомендовал его использовать.
> Кажется, там ещё и дырка последняя не заткнута...

для себя собрал в hasher + CVE-2012-5671.patch из debian, жалко что бесхозный.
------- Comment #5 From 2013-03-04 19:20:50 -------
Может, оприходуете? (а нет, так хоть забросьте мне спек+патч почтой)
------- Comment #6 From 2013-03-05 09:48:12 -------
Created an attachment (id=5760) [details]
CVE-2012-5671.patch
------- Comment #7 From 2013-03-05 09:54:16 -------
в спеке добавить

--- exim.spec.orig      2013-03-05 08:52:20.346252322 +0300
+++ exim.spec   2013-03-05 08:52:16.250272289 +0300
@@ -48,6 +48,7 @@
 Patch1: exim-4.72-buildoptions.patch
 Patch3: exim-4.34-texinfo.patch
 Patch4: exim-4.76-pcre.patch
+Patch5: CVE-2012-5671.patch

 # Automatically added by buildreq on Tue Apr 26 2011
 # ...and edited:
@@ -211,6 +212,7 @@
 #patch3 -p1

 %patch4 -p1
+%patch5 -p1

 install %SOURCE21 Local/eximon.conf

@@ -393,7 +395,7 @@
 %_bindir/exiqsumm
 %_bindir/exiqgrep
 #%attr( 755,root,root) %{_sbindir}/exim
-%_sbindir/mailq
+#%_sbindir/mailq
 %_sbindir/rmail
 %_sbindir/rsmtp
 %_sbindir/runq

ну и changelog добавить
------- Comment #8 From 2013-03-20 00:50:41 -------
Спасибо, отправил; а не хотите до 4.80.1 обновить?
------- Comment #9 From 2013-03-20 01:05:26 -------
exim-4.76-alt3 -> sisyphus:

* Tue Mar 19 2013 Michael Shigorin <mike@altlinux> 4.76-alt3
- NMU:
  + applied CVE-2012-5671.patch
  + dropped mailq symlink duplicating sendmail-common's one (ALT#28006)