Bug 28009 - Восстановить работу plymouth в свежеустановленных дистрибутивах
: Восстановить работу plymouth в свежеустановленных дистрибутивах
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/plymouth)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 27685
  Show dependency tree
 
Reported: 2012-11-20 18:22 by
Modified: 2013-02-07 11:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-11-20 18:22:21
Восстановить работу plymouth в свежеустановленных дистрибутивах, как с systemd,
так и без оного, обеспечить ввод пароля для LUKS.
------- Comment #1 From 2012-11-20 20:23:16 -------
JFYI, у меня на m-p plymouth продолжает работать на свежеустановленных
desktop-plymouth или специально сделанном
http://ftp.linux.kiev.ua/pub/Linux/ALT/people/mike/iso/mkimage-profiles/tmp/desktop-systemd-plumouth-20121120-i586.iso

Про ввод пароля с plymouth читал в описаниях тем, но не более.
------- Comment #2 From 2012-11-20 22:10:55 -------
На 3.6.7-std-def plymouth заработал. c systemd
На 3.6.4-un-def при загрузке не работал.
------- Comment #3 From 2012-11-21 10:49:50 -------
(В ответ на комментарий №1)
> JFYI, у меня на m-p plymouth продолжает работать на свежеустановленных
> desktop-plymouth или специально сделанном
> http://ftp.linux.kiev.ua/pub/Linux/ALT/people/mike/iso/mkimage-profiles/tmp/desktop-systemd-plumouth-20121120-i586.iso
А в kvm работает? Возможно, проблема связана с железом или "железом"

> Про ввод пароля с plymouth читал в описаниях тем, но не более.
Аналогично.
------- Comment #4 From 2012-11-21 12:21:01 -------
(В ответ на комментарий №1)
> JFYI, у меня на m-p plymouth продолжает работать на свежеустановленных
> desktop-plymouth или специально сделанном
> http://ftp.linux.kiev.ua/pub/Linux/ALT/people/mike/iso/mkimage-profiles/tmp/desktop-systemd-plumouth-20121120-i586.iso
А на x86_64 работает?
------- Comment #5 From 2012-11-21 12:24:50 -------
(В ответ на комментарий №1)
> JFYI, у меня на m-p plymouth продолжает работать на свежеустановленных
> desktop-plymouth или специально сделанном
> http://ftp.linux.kiev.ua/pub/Linux/ALT/people/mike/iso/mkimage-profiles/tmp/desktop-systemd-plumouth-20121120-i586.iso
в kvm этот образ не может запустить Xorg
------- Comment #6 From 2012-11-21 13:04:15 -------
Тестирование показало, что plymouth совсем не работает в kvm, но работает, в
vesa-framebuffer и, возможно, на kms-enabled железе.

Буду сначала разбираться с запросом пароля на vesa-fb, с kvm -- потом.
------- Comment #7 From 2012-11-21 13:29:36 -------
(В ответ на комментарий №6)
> Тестирование показало, что plymouth совсем не работает в kvm, но работает, в
> vesa-framebuffer и, возможно, на kms-enabled железе.
> 
> Буду сначала разбираться с запросом пароля на vesa-fb, с kvm -- потом.

Запрос пароля работает.
plymouth --ask-for-password выводит форму запроса пароля и возвращает введённый
пароль.
------- Comment #8 From 2012-11-21 17:08:22 -------
(In reply to comment #5)
> > http://ftp.linux.kiev.ua/pub/Linux/ALT/people/mike/iso/mkimage-profiles/tmp/desktop-systemd-plumouth-20121120-i586.iso
> в kvm этот образ не может запустить Xorg
Да, сейчас уже заметил.  Что-то новое, в /tmp/install2.log и dmesg ничего
внятного; xorg-drv-modesetting в install2 есть.

Проверил на AMD C60 -- plymouth нет при включении, но отрабатывает при
выключении (make-initrd-plymouth в устанавливаемой системе есть); подобные
грабли когда-то чинил для live, тогда был вопрос на состав initrd.

(In reply to comment #4)
> А на x86_64 работает?
На virtualbox -- да; выложил рядом:
http://ftp.linux.kiev.ua/pub/Linux/ALT/people/mike/iso/mkimage-profiles/tmp/desktop-systemd-plumouth-20121120-x86_64.iso
------- Comment #9 From 2013-02-07 11:43:00 -------
plymouth сейчас работает везде, кроме kvm с kms: и в vesa framebuffer и в
kms-enabled железе