Bug 28220 - ошибка при установке apache2-mod_perl
: ошибка при установке apache2-mod_perl
Status: CLOSED DUPLICATE of bug 26892
: Sisyphus
(All bugs in Sisyphus/apache2-mod_perl)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-12-13 17:13 by
Modified: 2012-12-13 18:39 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-12-13 17:13:30
Последний Sisyphus, обновленный dist-upgrade. Ядро 3.6.10-std-def-alt1 #1 SMP
Tue Dec 11 06:56:31 UTC 2012 x86_64 GNU/Linux При попытке установить пакет
apache2-mod_perl получаем:

# apt-get install apache2-mod_perl
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие НОВЫЕ пакеты будут установлены:
  apache2-mod_perl
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 0 не будет
обновлено.
Необходимо получить 0B/401kB архивов.
После распаковки потребуется дополнительно 2429kB дискового пространства.
Совершаем изменения...
Preparing...                
########################################################## [100%]
1: apache2-mod_perl         
########################################################## [100%]
Port config http.conf is already enabled!
Extra config httpd-addon.d.conf is already enabled!
Extra config httpd-autoindex.conf is already enabled!
Extra config httpd-default.conf is already enabled!
Extra config httpd-icons.conf is already enabled!
Extra config httpd-languages.conf is already enabled!
Extra config httpd-mime.conf is already enabled!
Extra config httpd-mpm.conf is already enabled!
Extra config httpd-multilang-errordoc.conf is already enabled!
Site config .confThis site is already enabled!
Site config .confThis site is already enabled!
Site config .conf is already disabled, or does not exist!
Module alias is already enabled!
Module alias installed;
        run service httpd2 condreload to fully enable.
Module authz_host is already enabled!
Module authz_host installed;
        run service httpd2 condreload to fully enable.
Module autoindex is already enabled!
Module autoindex installed;
        run service httpd2 condreload to fully enable.
Module dir is already enabled!
Module dir installed;
        run service httpd2 condreload to fully enable.
Module include is already enabled!
Module include installed;
        run service httpd2 condreload to fully enable.
Module log_config is already enabled!
Module log_config installed;
        run service httpd2 condreload to fully enable.
Module logio is already enabled!
Module logio installed;
        run service httpd2 condreload to fully enable.
Module mime is already enabled!
Module mime installed;
        run service httpd2 condreload to fully enable.
Module mod_php5 is already enabled!
Module mod_php5 installed;
        run service httpd2 condreload to fully enable.
Module negotiation is already enabled!
Module negotiation installed;
        run service httpd2 condreload to fully enable.
Module perl installed;
        run service httpd2 condreload to fully enable.
Starting httpd2 service:   [FAILED]
/usr/lib/rpm/zz-apache2-base.filetrigger failed
error: execution of /usr/lib/rpm/posttrans-filetriggers scriptlet from
(null)-(null)-(null) failed, exit status 1
Завершено.

В результате Apache не стартует, ручной рестарт результатов не даёт, в логах
Apache никаких ошибок нет. Лечится удалением apache2-mod_perl и перезапуском
Apache.
------- Comment #1 From 2012-12-13 18:22:19 -------
Это следствие #26892 / #27924 .
Apache2 запускается вполне успешно, и нормально работает - поэтому ошибок в его
логах и нет. Только service httpd2 status его в запущенном состоянии найти не
может.

*** This bug has been marked as a duplicate of bug 26892 ***
------- Comment #2 From 2012-12-13 18:39:11 -------
(В ответ на комментарий №1)
> Это следствие #26892 / #27924 .
> Apache2 запускается вполне успешно, и нормально работает - поэтому ошибок в его
> логах и нет. Только service httpd2 status его в запущенном состоянии найти не
> может.
> 
> *** Ошибка отмечена как повтор ошибки 26892 ***

А нельзя ли где-то вручную изменить имя процесса на правильное (/usr/sbin/httpd
на /usr/sbin/httpd2), чтобы не ждать решения задачи #26892, которая уже почти
год без решения ? Какой файл нужно отредактировать ?