Bug 28299 - Не соответствует имя пакета тому что он провайдит
: Не соответствует имя пакета тому что он провайдит
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/python-module-pam)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-01-02 18:32 by
Modified: 2013-03-02 12:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-01-02 18:32:53
пакет называется python-module-pam
При этом провайдит он python2.7(PAM).

[slava@dubrwork ~]$ apt-cache show python-module-pam
Section: Development/Python
Installed Size: 51145
Maintainer: Pavel Shilovsky <piastry@altlinux.org>
Version: 0.5.0-alt1
Pre-Depends: rpmlib(SetVersions), rpmlib(PayloadIsLzma)
Depends: python, /usr/lib64/python2.7/site-packages,
libc.so.6(GLIBC_2.2.5)(64bit), libc.so.6(GLIBC_2.3.4)(64bit),
libc.so.6(GLIBC_2.4)(64bit), libpam.so.0()(64bit) (>=
set:jfaUklyx6tKEeF9THI4O8Z4blHqA5quJKn), libpam.so.0(LIBPAM_1.0)(64bit),
libpam_misc.so.0()(64bit) (>= set:hgpx0),
libpam_misc.so.0(LIBPAM_MISC_1.0)(64bit), libpthread.so.0()(64bit),
rtld(GNU_HASH)
Provides: python2.7(PAM), python2.7(PAMmodule), python-module-pam (=
0.5.0-alt1)
Architecture: x86_64
Size: 19765
MD5Sum: 8a8e33d7842f3a96fb8570f8cf68e7f9
Filename: python-module-pam-0.5.0-alt1.x86_64.rpm
Description: PAM bindings for Python
 PAM (Pluggable Authentication Module) bindings for Python.
Changelog:
 * Пн сен 17 2012 Pavel Shilovsky <piastry@altlinux.org> 0.5.0-alt1
 - Initial release for Sisyphus (based on Fedora)

Предлагаю переименовать пакет в python-module-PAM

Также есть пакет http://pypi.python.org/pypi/pam, который должен называться
python-module-pam
------- Comment #1 From 2013-03-02 12:16:20 -------
Собрал в Sisyphus python-module-PAM-0.5.0-alt2. Так же исправил зависимость в
openstack-keystone-2012.2.0.6-alt2.