Bug 28497 - wrong path to memtest when /boot/ is on a separate partition
: wrong path to memtest when /boot/ is on a separate partition
Status: CLOSED DUPLICATE of bug 26178
: Branch t6
(All bugs in Branch t6/grub2)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 26178
  Show dependency tree
 
Reported: 2013-02-02 17:35 by
Modified: 2013-11-27 00:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-02-02 17:35:53
(This problem would also affect t6.)

+++ This bug was initially created as a clone of Bug #26178 +++

# tail -30 /boot/grub/grub.cfg
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/39_memtest ###
menuentry "Memtest86+-3.5" {
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos2)'
    search --no-floppy --fs-uuid --set=root
ac12087e-a82d-413e-8abc-7a9fc1f62ea5
    linux16 /boot/memtest-3.5.bin
}
menuentry "Memtest86+-4.20" {
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos2)'
    search --no-floppy --fs-uuid --set=root
ac12087e-a82d-413e-8abc-7a9fc1f62ea5
    linux16 /boot/memtest-4.20.bin
}
### END /etc/grub.d/39_memtest ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###
# rpm -qf /etc/grub.d/39_memtest 
grub2-1.99-alt7
# 

This doesn't work in my case, because in my case /boot/ is on a separate
partition, and hence the path to memtest is wrong:

# mount | fgrep /boot
/dev/sda2 on /boot type ext4
(rw,nosuid,nodev,noexec,relatime,user_xattr,acl,barrier=1,data=ordered)
# 

Some more info:

# rpm -qa 'memtest*'
memtester-4.2.1-alt1
memtest86+-4.20-alt1
memtest86-3.5-alt2
#
------- Comment #1 From 2013-11-27 00:22:52 -------
+++ This bug was initially created as a duplicate of Bug #26178 +++

*** This bug has been marked as a duplicate of bug 26178 ***