Bug 28508 - Ошибка в установочном скрипте пакета.
: Ошибка в установочном скрипте пакета.
Status: CLOSED FIXED
: Branch p6
(All bugs in Branch p6/sugarcrm)
: не указана
: all Linux
: P3 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-02-04 21:33 by
Modified: 2013-02-06 10:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-02-04 21:33:58
Пакет sugarcrm-5.5.0-alt1.noarch.rpm файл
/var/www/webapps/sugarcrm/install/welcome.php
Присутствуют строки:
if (version_compare(phpversion(),'5.1.0') < 0 ||
version_compare(phpversion(),'5.3.0') >= 0) {
    if(empty($mod_strings['LBL_MINIMUM_PHP_VERSION'])){
        $mod_strings['LBL_MINIMUM_PHP_VERSION'] = 'Minimum Php version required
is 5.1.0. Recommended Php version is 5.2.x.';
    }
С учётом того, что в самом дистрибутиве установлена версия php 5.3.18 во время
установки получаем облом. Приходится ручками версию править на более свежую,
тогда установка проходит. В работе ещё особо не тестировал, но думаю ляпов быть
не должно.
------- Comment #1 From 2013-02-05 11:30:46 -------
На конкретный пакет.
------- Comment #2 From 2013-02-06 10:13:48 -------
sugarcrm-5.5.0-alt1.M60P.1 -> p6:

* Tue Feb 05 2013 Andrey Cherepanov <cas@altlinux> 5.5.0-alt1.M60P.1
- Increase maximum supported PHP version (ALT #28508)