Bug 28511 - please, package gtk-update-icon-cache from libgtk+3, for example, as gtk-update-icon-cache-3.0
: please, package gtk-update-icon-cache from libgtk+3, for example, as gtk-upda...
Status: NEW
: Sisyphus
(All bugs in Sisyphus/libgtk+3)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-02-05 16:40 by
Modified: 2013-02-20 16:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-02-05 16:40:02
Столкнулся с тем, что свежая версия темы mate-faenza инталлируется в формате,
который не поддерживается нашим gtk-update-icon-cache из gtk+2 - icons are not
in subfolders named WIDTHxHEIGHT (icon dimensions)
gtk-update-icon-cache понимает тоько формат WIDTHxHEIGHT (icon dimensions) 
а там свое описание в index.theme, понятное libgtk, но не нашему
gtk-update-icon-cache.из libgtk+2.
Он на такой теме отрабатывает, создает какой-то кеш, но 
завершается с exit 1 и сообщением the generated cache was invalid.

Возможно, в этом и наша вина; возможно, пора бы уже начать с того, чтобы уже
паковать gtk-update-icon-cache.из libgtk+3, хотя бы под другим именем.
Или просто собрать подпакет gtk-update-icon-cache из libgtk+3,
если формат кеша обратно совместимый.
------- Comment #1 From 2013-02-20 15:24:34 -------
(In reply to comment #0)
> Или просто собрать подпакет gtk-update-icon-cache из libgtk+3,
> если формат кеша обратно совместимый.

Проверьте.
------- Comment #2 From 2013-02-20 16:24:28 -------
(В ответ на комментарий №1)
> (In reply to comment #0)
> > Или просто собрать подпакет gtk-update-icon-cache из libgtk+3,
> > если формат кеша обратно совместимый.
> 
> Проверьте.

чтобы проверить, надо
> начать с того, чтобы уже
> иметь упаковнный gtk-update-icon-cache.из libgtk+3, хотя бы под другим именем.