Bug 2857 - mega deps
: mega deps
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/grip)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-08-19 13:09 by
Modified: 2004-06-09 13:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-08-19 13:09:24
[<a href="mailto:root@horror" target="_new">root@horror</a> root]# rpm -q grip
grip-3.0.7-alt1
[<a href="mailto:root@horror" target="_new">root@horror</a> root]# apt-get dist-upgrade
Reading Package Lists... Done
Collecting File Provides... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be upgraded
  grip
The following NEW packages will be installed:
  GConf2 ORBit2 gnome-mime-data gnome-settings gnome-vfs2 icons-BlueSphere libGConf2 libIDL
  libORBit2 libbonobo2 libbonoboui libfam libglade2 libgmp libgnome libgnomecanvas libgnomeui
  liblinc python22 xml-utils
1 packages upgraded, 20 newly installed, 0 removed and 0 not upgraded.
Need to get 8904kB/12.7MB of archives.
After unpacking 32.0MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
[<a href="mailto:root@horror" target="_new">root@horror</a> root]# 
---

---

------- Comment #1 From 2003-08-19 15:33:16 -------
README:
---
Requirements
============

To use Grip, you must have:

 o The Gnome desktop
---

trickster:~&gt; ldd /usr/bin/grip
        libcdda_interface.so.0 =&gt; /usr/lib/libcdda_interface.so.0 (0x00122000)
        libcdda_paranoia.so.0 =&gt; /usr/lib/libcdda_paranoia.so.0 (0x00133000)
        libid3-3.8.so.3 =&gt; /usr/lib/libid3-3.8.so.3 (0x0013d000)
        libstdc++.so.5 =&gt; /usr/lib/libstdc++.so.5 (0x0018e000)
        libgnomeui-2.so.0 =&gt; /usr/lib/libgnomeui-2.so.0 (0x0023f000)
        libjpeg.so.62 =&gt; /usr/lib/libjpeg.so.62 (0x002cf000)
        libbonoboui-2.so.0 =&gt; /usr/lib/libbonoboui-2.so.0 (0x002ed000)
        libSM.so.6 =&gt; /usr/X11R6/lib/libSM.so.6 (0x00350000)
        libICE.so.6 =&gt; /usr/X11R6/lib/libICE.so.6 (0x00359000)
        libX11.so.6 =&gt; /usr/X11R6/lib/libX11.so.6 (0x00370000)
        libgnomecanvas-2.so.0 =&gt; /usr/lib/libgnomecanvas-2.so.0 (0x00438000)
        libgnome-2.so.0 =&gt; /usr/lib/libgnome-2.so.0 (0x00465000)
        libesd.so.0 =&gt; /usr/lib/libesd.so.0 (0x00479000)
        libaudiofile.so.0 =&gt; /usr/lib/libaudiofile.so.0 (0x00481000)
        libart_lgpl_2.so.2 =&gt; /usr/lib/libart_lgpl_2.so.2 (0x004a3000)
        libpangoft2-1.0.so.0 =&gt; /usr/lib/libpangoft2-1.0.so.0 (0x004ba000)
        libgtk-x11-2.0.so.0 =&gt; /usr/lib/libgtk-x11-2.0.so.0 (0x004dc000)
        libgdk-x11-2.0.so.0 =&gt; /usr/lib/libgdk-x11-2.0.so.0 (0x00731000)
        libatk-1.0.so.0 =&gt; /usr/lib/libatk-1.0.so.0 (0x0079e000)
        libgdk_pixbuf-2.0.so.0 =&gt; /usr/lib/libgdk_pixbuf-2.0.so.0 (0x007b8000)
        libpangoxft-1.0.so.0 =&gt; /usr/lib/libpangoxft-1.0.so.0 (0x007cb000)
        libpangox-1.0.so.0 =&gt; /usr/lib/libpangox-1.0.so.0 (0x007ec000)
        libpango-1.0.so.0 =&gt; /usr/lib/libpango-1.0.so.0 (0x007f9000)
        libbonobo-2.so.0 =&gt; /usr/lib/libbonobo-2.so.0 (0x0082c000)
        libgnomevfs-2.so.0 =&gt; /usr/lib/libgnomevfs-2.so.0 (0x00882000)
        libgconf-2.so.4 =&gt; /usr/lib/libgconf-2.so.4 (0x008bd000)
        libxml2.so.2 =&gt; /usr/lib/libxml2.so.2 (0x008f3000)
        libz.so.1 =&gt; /lib/libz.so.1 (0x009ed000)
        libssl.so.0 =&gt; /lib/libssl.so.0 (0x009fc000)
        libcrypto.so.0 =&gt; /lib/libcrypto.so.0 (0x00a2b000)
        libpthread.so.0 =&gt; /lib/libpthread.so.0 (0x00aec000)
        librt.so.1 =&gt; /lib/librt.so.1 (0x00b01000)
        libbonobo-activation.so.4 =&gt; /usr/lib/libbonobo-activation.so.4 (0x00b13000)
        libORBitCosNaming-2.so.0 =&gt; /usr/lib/libORBitCosNaming-2.so.0 (0x00b26000)
        libIDL-2.so.0 =&gt; /usr/lib/libIDL-2.so.0 (0x00b34000)
        libORBit-2.so.0 =&gt; /usr/lib/libORBit-2.so.0 (0x00b5b000)
        libpopt.so.0 =&gt; /lib/libpopt.so.0 (0x00ba8000)
        libgobject-2.0.so.0 =&gt; /usr/lib/libgobject-2.0.so.0 (0x00baf000)
        libgthread-2.0.so.0 =&gt; /usr/lib/libgthread-2.0.so.0 (0x00be4000)
        libgmodule-2.0.so.0 =&gt; /usr/lib/libgmodule-2.0.so.0 (0x00bea000)
        libdl.so.2 =&gt; /lib/libdl.so.2 (0x00bee000)
        libglib-2.0.so.0 =&gt; /usr/lib/libglib-2.0.so.0 (0x00bf1000)
        libghttp.so.1 =&gt; /usr/lib/libghttp.so.1 (0x00c5b000)
        libm.so.6 =&gt; /lib/libm.so.6 (0x00c63000)
        libgcc_s.so.1 =&gt; /lib/libgcc_s.so.1 (0x00c86000)
        libc.so.6 =&gt; /lib/libc.so.6 (0x00c8e000)
        libfontconfig.so.1 =&gt; /usr/lib/libfontconfig.so.1 (0x00daa000)
        libfreetype.so.6 =&gt; /usr/lib/libfreetype.so.6 (0x00dd1000)
        libXrandr.so.2 =&gt; /usr/X11R6/lib/libXrandr.so.2 (0x00e27000)
        libXi.so.6 =&gt; /usr/X11R6/lib/libXi.so.6 (0x00e2b000)
        libXinerama.so.1 =&gt; /usr/X11R6/lib/libXinerama.so.1 (0x00e33000)
        libXext.so.6 =&gt; /usr/X11R6/lib/libXext.so.6 (0x00e36000)
        libXft.so.2 =&gt; /usr/X11R6/lib/libXft.so.2 (0x00e44000)
        libXrender.so.1 =&gt; /usr/X11R6/lib/libXrender.so.1 (0x00e57000)
        /lib/ld-linux.so.2 =&gt; /lib/ld-linux.so.2 (0x80000000)
        libexpat.so.0 =&gt; /usr/lib/libexpat.so.0 (0x00e5f000)
------- Comment #2 From 2003-08-19 15:33:16 -------
README:
---
Requirements
============

To use Grip, you must have:

 o The Gnome desktop
---

trickster:~&gt; ldd /usr/bin/grip
        libcdda_interface.so.0 =&gt; /usr/lib/libcdda_interface.so.0 (0x00122000)
        libcdda_paranoia.so.0 =&gt; /usr/lib/libcdda_paranoia.so.0 (0x00133000)
        libid3-3.8.so.3 =&gt; /usr/lib/libid3-3.8.so.3 (0x0013d000)
        libstdc++.so.5 =&gt; /usr/lib/libstdc++.so.5 (0x0018e000)
        libgnomeui-2.so.0 =&gt; /usr/lib/libgnomeui-2.so.0 (0x0023f000)
        libjpeg.so.62 =&gt; /usr/lib/libjpeg.so.62 (0x002cf000)
        libbonoboui-2.so.0 =&gt; /usr/lib/libbonoboui-2.so.0 (0x002ed000)
        libSM.so.6 =&gt; /usr/X11R6/lib/libSM.so.6 (0x00350000)
        libICE.so.6 =&gt; /usr/X11R6/lib/libICE.so.6 (0x00359000)
        libX11.so.6 =&gt; /usr/X11R6/lib/libX11.so.6 (0x00370000)
        libgnomecanvas-2.so.0 =&gt; /usr/lib/libgnomecanvas-2.so.0 (0x00438000)
        libgnome-2.so.0 =&gt; /usr/lib/libgnome-2.so.0 (0x00465000)
        libesd.so.0 =&gt; /usr/lib/libesd.so.0 (0x00479000)
        libaudiofile.so.0 =&gt; /usr/lib/libaudiofile.so.0 (0x00481000)
        libart_lgpl_2.so.2 =&gt; /usr/lib/libart_lgpl_2.so.2 (0x004a3000)
        libpangoft2-1.0.so.0 =&gt; /usr/lib/libpangoft2-1.0.so.0 (0x004ba000)
        libgtk-x11-2.0.so.0 =&gt; /usr/lib/libgtk-x11-2.0.so.0 (0x004dc000)
        libgdk-x11-2.0.so.0 =&gt; /usr/lib/libgdk-x11-2.0.so.0 (0x00731000)
        libatk-1.0.so.0 =&gt; /usr/lib/libatk-1.0.so.0 (0x0079e000)
        libgdk_pixbuf-2.0.so.0 =&gt; /usr/lib/libgdk_pixbuf-2.0.so.0 (0x007b8000)
        libpangoxft-1.0.so.0 =&gt; /usr/lib/libpangoxft-1.0.so.0 (0x007cb000)
        libpangox-1.0.so.0 =&gt; /usr/lib/libpangox-1.0.so.0 (0x007ec000)
        libpango-1.0.so.0 =&gt; /usr/lib/libpango-1.0.so.0 (0x007f9000)
        libbonobo-2.so.0 =&gt; /usr/lib/libbonobo-2.so.0 (0x0082c000)
        libgnomevfs-2.so.0 =&gt; /usr/lib/libgnomevfs-2.so.0 (0x00882000)
        libgconf-2.so.4 =&gt; /usr/lib/libgconf-2.so.4 (0x008bd000)
        libxml2.so.2 =&gt; /usr/lib/libxml2.so.2 (0x008f3000)
        libz.so.1 =&gt; /lib/libz.so.1 (0x009ed000)
        libssl.so.0 =&gt; /lib/libssl.so.0 (0x009fc000)
        libcrypto.so.0 =&gt; /lib/libcrypto.so.0 (0x00a2b000)
        libpthread.so.0 =&gt; /lib/libpthread.so.0 (0x00aec000)
        librt.so.1 =&gt; /lib/librt.so.1 (0x00b01000)
        libbonobo-activation.so.4 =&gt; /usr/lib/libbonobo-activation.so.4 (0x00b13000)
        libORBitCosNaming-2.so.0 =&gt; /usr/lib/libORBitCosNaming-2.so.0 (0x00b26000)
        libIDL-2.so.0 =&gt; /usr/lib/libIDL-2.so.0 (0x00b34000)
        libORBit-2.so.0 =&gt; /usr/lib/libORBit-2.so.0 (0x00b5b000)
        libpopt.so.0 =&gt; /lib/libpopt.so.0 (0x00ba8000)
        libgobject-2.0.so.0 =&gt; /usr/lib/libgobject-2.0.so.0 (0x00baf000)
        libgthread-2.0.so.0 =&gt; /usr/lib/libgthread-2.0.so.0 (0x00be4000)
        libgmodule-2.0.so.0 =&gt; /usr/lib/libgmodule-2.0.so.0 (0x00bea000)
        libdl.so.2 =&gt; /lib/libdl.so.2 (0x00bee000)
        libglib-2.0.so.0 =&gt; /usr/lib/libglib-2.0.so.0 (0x00bf1000)
        libghttp.so.1 =&gt; /usr/lib/libghttp.so.1 (0x00c5b000)
        libm.so.6 =&gt; /lib/libm.so.6 (0x00c63000)
        libgcc_s.so.1 =&gt; /lib/libgcc_s.so.1 (0x00c86000)
        libc.so.6 =&gt; /lib/libc.so.6 (0x00c8e000)
        libfontconfig.so.1 =&gt; /usr/lib/libfontconfig.so.1 (0x00daa000)
        libfreetype.so.6 =&gt; /usr/lib/libfreetype.so.6 (0x00dd1000)
        libXrandr.so.2 =&gt; /usr/X11R6/lib/libXrandr.so.2 (0x00e27000)
        libXi.so.6 =&gt; /usr/X11R6/lib/libXi.so.6 (0x00e2b000)
        libXinerama.so.1 =&gt; /usr/X11R6/lib/libXinerama.so.1 (0x00e33000)
        libXext.so.6 =&gt; /usr/X11R6/lib/libXext.so.6 (0x00e36000)
        libXft.so.2 =&gt; /usr/X11R6/lib/libXft.so.2 (0x00e44000)
        libXrender.so.1 =&gt; /usr/X11R6/lib/libXrender.so.1 (0x00e57000)
        /lib/ld-linux.so.2 =&gt; /lib/ld-linux.so.2 (0x80000000)
        libexpat.so.0 =&gt; /usr/lib/libexpat.so.0 (0x00e5f000)
------- Comment #3 From 2003-08-19 15:34:16 -------
I proposed to package grip-3.0.x separately (as grip-gtk1?) for those who may
need that but nobody requested it as needed (yet).
------- Comment #4 From 2003-08-19 15:34:16 -------
I proposed to package grip-3.0.x separately (as grip-gtk1?) for those who may
need that but nobody requested it as needed (yet).