Bug 28807 - Приложение dia падает
: Приложение dia падает
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/dia)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 27685
  Show dependency tree
 
Reported: 2013-04-07 20:38 by
Modified: 2013-04-08 06:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-04-07 20:38:08
Centaurus 7b в VirtualBox, 1024x768, драйвер vesa
Редактор диаграмм dia открывается и падает при запуске.
Вывод в терминале:

$ dia

(dia:3701): GLib-GObject-WARNING **: attempting to add an interface
(DiaInteractiveRendererInterface) to class (DiaGdkRenderer) after class_init

** (dia:3701): CRITICAL **: dia_renderer_set_size: assertion `irenderer !=
NULL' failed

** (dia:3701): CRITICAL **: dia_renderer_set_size: assertion `irenderer !=
NULL' failed
Ошибка сегментирования
------- Comment #1 From 2013-04-07 22:12:32 -------
Патчи есть тут:
http://mirror.yandex.ru/fedora/linux/development/rawhide/source/SRPMS/d/dia-0.97.2-4.fc20.src.rpm
------- Comment #2 From 2013-04-08 05:35:36 -------
Бага в багзилле upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=694025

Бага в Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/dia/+bug/1102960

Патчей пока нет, как я понял. Проблема из-за изменений в glib/gtk.
------- Comment #3 From 2013-04-08 06:22:18 -------
dia-0.97.2-alt2 -> sisyphus:

* Mon Apr 08 2013 Vitaly Lipatov <lav@altlinux> 0.97.2-alt2
- fix Bug 694025 - GLib drop support for adding interfaces after class_init
(ALT bug #28807)
- cleanup build
------- Comment #4 From 2013-04-08 06:24:27 -------
(В ответ на комментарий №3)
> dia-0.97.2-alt2 -> sisyphus:
> 
> * Mon Apr 08 2013 Vitaly Lipatov <lav@altlinux> 0.97.2-alt2
> - fix Bug 694025 - GLib drop support for adding interfaces after class_init
> (ALT bug #28807)
> - cleanup build

Спасибо!