Bug 2890 - esound-0.2.31-alt1 doesn't work with OSS
: esound-0.2.31-alt1 doesn't work with OSS
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/esound)
: unstable
: all Linux
: P5 blocker
Assigned To:
:
:
:
:
: 3005
  Show dependency tree
 
Reported: 2003-08-27 19:32 by
Modified: 2005-07-13 15:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-08-27 19:32:43
Возникли серьёзные проблемы при обновлении с 0.2.29-alt3 до 0.2.31-alt1: 

У меня в качестве звукового драйвера используется i810_audio (OSS, а не alsa), 
в результате всего во всех программах, собранных с libesd.so.0, пропал звук. 
Вот что происходит, например, с mpg123: 

$ mpg123 sample.mp3 
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2 and 3. 
Version 0.59s-mh4 (2000/Oct/27). Written and copyrights by Michael Hipp. 
Uses code from various people. See 'README' for more! 
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT 
YOUR OWN RISK! 
audio_alsa: no cards found! 
audio_alsa: no cards found! 
audio_alsa: no cards found! 
audio_alsa: no cards found! 
audio_alsa: no cards found! 
audio: No such file or directory 

Мне пришлось откатить esound на предыдущую версию. 
Но проблему надо решать в принципе.
------- Comment #1 From 2003-09-22 12:11:16 -------
2aris: нужно ускорить решение проблемы, ибо это ошибка является блокирующей для
выхода следующего дистрибутива.
------- Comment #2 From 2003-09-22 13:55:56 -------
fixed in 0.2.31-alt2
------- Comment #3 From 2003-09-24 22:23:09 -------
I see no esound-0.2.31-alt2 so far... 
------- Comment #4 From 2003-09-24 22:34:14 -------
see esound-0.2.32-alt1
------- Comment #5 From 2003-09-28 03:05:21 -------
кажется, работает.