Bug 28932 - Ошибка установки/обновления пакетов "E: Ошибка во время исполнения транзакции"
: Ошибка установки/обновления пакетов "E: Ошибка во время исполнения транзакции"
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-05-05 10:35 by
Modified: 2013-05-05 12:23 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-05-05 10:35:35
Ошибка возникает при установке новых пакетов либо при проведении upgrade или
dist-upgrade. В попытках установить обновляемые пакеты поодиночке новые версии
нескольких пакетов были установлены, но у оставшихся это также приводит к той
же ошибке.

bash-3.2$ sudo apt-get install rpm-build
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  autoconf-common autoconf_2.60 automake-common automake_1.11 bison
bison-runtime elfutils gettext-tools libtool-common
  libtool_2.2 libunistring m4 patch perl-threads rpm-build-perl
rpm-build-python rpm-macros-info-install tex-common
  texinfo
Следующие НОВЫЕ пакеты будут установлены:
  autoconf-common autoconf_2.60 automake-common automake_1.11 bison
bison-runtime elfutils gettext-tools libtool-common
  libtool_2.2 libunistring m4 patch perl-threads rpm-build rpm-build-perl
rpm-build-python rpm-macros-info-install
  tex-common texinfo
0 будет обновлено, 20 новых установлено, 0 пакетов будет удалено и 13 не будет
обновлено.
Необходимо получить 0B/5175kB архивов.
После распаковки потребуется дополнительно 18,1MB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Preparing...                
######################################################################################
[100%]
installing package autoconf_2.60-2.65-alt3 needs 940Kb on the / filesystem
installing package tex-common-0.2-alt4 needs 976Kb on the / filesystem
installing package rpm-macros-info-install-4.13-alt8 needs 980Kb on the /
filesystem
installing package texinfo-4.13-alt8 needs 4Mb on the / filesystem
installing package rpm-build-python-0.34.5-alt5.M60P.1 needs 4Mb on the /
filesystem
installing package rpm-build-perl-0.74-alt1 needs 4Mb on the / filesystem
installing package perl-threads-5.12.5-alt1.M60P.1 needs 4Mb on the /
filesystem
installing package automake_1.11-1.11.1-alt3 needs 6Mb on the / filesystem
installing package patch-2.6.1-alt4 needs 6Mb on the / filesystem
installing package libtool-common-0.2-alt3 needs 6Mb on the / filesystem
installing package libtool_2.2-2.2.10-alt3 needs 8Mb on the / filesystem
installing package libunistring-0.9.3-alt3 needs 9Mb on the / filesystem
installing package gettext-tools-0.18.1.1-alt2 needs 16Mb on the / filesystem
installing package elfutils-0.152-alt1 needs 17Mb on the / filesystem
installing package bison-runtime-2.4.3-alt3 needs 17Mb on the / filesystem
installing package bison-2.4.3-alt3 needs 19Mb on the / filesystem
installing package rpm-build-4.0.4-alt100.24.M60P.4 needs 19Mb on the /
filesystem
E: Ошибка во время исполнения транзакции
bash-3.2$ sudo apt-get upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
  alterator-l10n apt-repo cups firmware-linux libcups libpq5.4 mc thunderbird
tzdata tzdata-java
Следующие пакеты будут СОХРАНЕНЫ:
  udisks
10 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 1 не будет
обновлено.
Необходимо получить 0B/37,1MB архивов.
После распаковки потребуется дополнительно 10,1MB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Preparing...                
######################################################################################
[100%]
installing package tzdata-2013b-alt1 needs 88Kb on the / filesystem
installing package libcups-1.5.4-alt0.M60P.1 needs 8Kb on the / filesystem
installing package alterator-l10n-2.9-alt58 needs 8Kb on the / filesystem
installing package apt-repo-1.1.2-alt1 needs 16Kb on the / filesystem
installing package firmware-linux-20130423-alt1 needs 11Mb on the / filesystem
installing package cups-1.5.4-alt0.M60P.1 needs 13Mb on the / filesystem
installing package mc-4.8.8-alt0.M60P.3 needs 11Mb on the / filesystem
installing package thunderbird-17.0.5-alt0.M60P.1 needs 11Mb on the /
filesystem
installing package tzdata-java-2013b-alt1 needs 11Mb on the / filesystem
installing package libpq5.4-9.1.9-alt0.M60T.1 needs 11Mb on the / filesystem
E: Ошибка во время исполнения транзакции
bash-3.2$ sudo apt-get dist-upgrade
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Подсчет обновлений... Завершено
Следующие пакеты будут ОБНОВЛЕНЫ:
  alterator-l10n apt-repo cups firmware-linux libcups libpq5.4 mc thunderbird
tzdata tzdata-java udisks
Следующие НОВЫЕ пакеты будут установлены:
  acl gdisk
11 будет обновлено, 2 новых установлено, 0 пакетов будет удалено и 0 не будет
обновлено.
Необходимо получить 0B/37,4MB архивов.
После распаковки потребуется дополнительно 10,6MB дискового пространства.
Продолжить? [Y/n] y
Совершаем изменения...
Preparing...                
######################################################################################
[100%]
installing package tzdata-2013b-alt1 needs 88Kb on the / filesystem
installing package libcups-1.5.4-alt0.M60P.1 needs 8Kb on the / filesystem
installing package gdisk-0.7.0-alt1 needs 424Kb on the / filesystem
installing package acl-2.2.51-alt1 needs 608Kb on the / filesystem
installing package alterator-l10n-2.9-alt58 needs 608Kb on the / filesystem
installing package apt-repo-1.1.2-alt1 needs 616Kb on the / filesystem
installing package firmware-linux-20130423-alt1 needs 12Mb on the / filesystem
installing package cups-1.5.4-alt0.M60P.1 needs 13Mb on the / filesystem
installing package mc-4.8.8-alt0.M60P.3 needs 12Mb on the / filesystem
installing package thunderbird-17.0.5-alt0.M60P.1 needs 11Mb on the /
filesystem
installing package tzdata-java-2013b-alt1 needs 11Mb on the / filesystem
installing package udisks-1.0.2-alt2.M60P.2 needs 11Mb on the / filesystem
installing package libpq5.4-9.1.9-alt0.M60T.1 needs 11Mb on the / filesystem
E: Ошибка во время исполнения транзакции


Сведения о версии и источниках пакетов:
bash-3.2$ cat /etc/altlinux-release
ALT Linux 6.0.0 LXDEsktop  (Liliya)
bash-3.2$ grep '^rpm' /etc/apt/sources.list.d/*.list
/etc/apt/sources.list.d/alt.list:rpm [p6]
http://ftp.altlinux.org/pub/distributions/ALTLinux/p6/branch i586 classic
/etc/apt/sources.list.d/alt.list:rpm [p6]
http://ftp.altlinux.org/pub/distributions/ALTLinux/p6/branch noarch classic
------- Comment #1 From 2013-05-05 12:23:46 -------
(In reply to comment #0)
> bash-3.2$ sudo apt-get dist-upgrade
> Чтение списков пакетов... Завершено
> Построение дерева зависимостей... Завершено
> Подсчет обновлений... Завершено
> Следующие пакеты будут ОБНОВЛЕНЫ:
>   alterator-l10n apt-repo cups firmware-linux libcups libpq5.4 mc thunderbird
> tzdata tzdata-java udisks
> Следующие НОВЫЕ пакеты будут установлены:
>   acl gdisk
> 11 будет обновлено, 2 новых установлено, 0 пакетов будет удалено и 0 не будет
> обновлено.
> Необходимо получить 0B/37,4MB архивов.
> После распаковки потребуется дополнительно 10,6MB дискового пространства.
> Продолжить? [Y/n] y
> Совершаем изменения...
> Preparing...                
> ######################################################################################
> [100%]
> installing package tzdata-2013b-alt1 needs 88Kb on the / filesystem

На файловой системе недостаточно свободного места для установки/обновления
пакетов.