Bug 28952 - Ошибка в установке: запуск скрипта не удался
: Ошибка в установке: запуск скрипта не удался
Status: NEW
: ALT Linux Centaurus
(All bugs in ALT Linux Centaurus/Установка)
: 7.0
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-05-09 22:54 by
Modified: 2015-03-04 16:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-05-09 22:54:02
при установке системы на реальном сервере (в виртуалке пока не наблюдал) после
установки всех пакетов на экране появляется надпись:
"Запуск скрипта не удался"
"destination filesystem remount error"
и при этом вечно бегает ползунок.

При нажатии на кнопку Next иксы дохнут.
в install2.log последнее: 
frame:back-activity is deprecated, use wizard-update-activity instead
ERROR: Unable to open url "/grub"

xinit: connection to X server lost

В wizard.log:
("/pkg-install/slideshow-config" language ("ru_RU") action "read")
;answer: ("/pkg-install/slideshow-config" step "30" once #f url
"/usr/share/install2/slideshow")
("/pkg-install" language ("ru_RU") action "write" lists "sysvinit")
;answer: empty
("/preinstall" language ("ru_RU") action "write")
;answer: empty
("/help/" language ("ru_RU") action "read" topic "preinstall")
;answer: ("/help" url "/usr/share/alterator/help/ru_RU/preinstall.html")


Я спас всё из /tmp, могу приложить необходимые файлы.
------- Comment #1 From 2013-05-10 15:28:11 -------
А файл /usr/lib/alterator/backend3/grub есть?
------- Comment #2 From 2013-05-10 15:51:19 -------
(В ответ на комментарий №1)
> А файл /usr/lib/alterator/backend3/grub есть?

Имеется ввиду в недоустановленной системе? 
сразу до отключения отладочной консоли не посмотрел.
Сейчас попробовал загрузить rescue - забавно, md есть, автивно-запущены, а LVM
нет.
pvscan говорит, что No matching physical volumes found.
------- Comment #3 From 2013-05-10 15:59:36 -------
Собственно, на MD-устройстве с 0 по 0030400 оказались нули. С 0030400 похоже на
заголовок swap-раздела, это был первый из LV в группе томов.

При повторном pvcreate на это устройство заголовки прописываются начиная с
00000200.

(имеются ввиду hex-offsets, показываемые hexdump -C).
------- Comment #4 From 2013-08-31 12:59:24 -------
Ошибка повторяется.
Проверял на 7.0.0 и 7.0.1.
29127 - вот на таком же железе.
Что то проверить не получается, ползунок бегает но на клавиатуру не реагирует.
Та же конфигурация - зеркало + lvm.
------- Comment #5 From 2013-10-25 22:46:06 -------
Не напоминает bug #29452 и bug #29471 часом?
------- Comment #6 From 2013-10-25 22:55:27 -------
(В ответ на комментарий №5)
> Не напоминает bug #29452 и bug #29471 часом?

Да, похоже.
После выходных проверю.
------- Comment #7 From 2015-03-04 11:32:51 -------
Сервер: Core i5, 8Гб ОЗУ, RAID1
Raid1 (зеркало), размечал по инструкции (создавал Linux RAID идентичные на
обоих дисках разделы, потом в ветке RAID доразметил, присвоил точки
монтирования)
На шаге 6 вылетела та же ошибка "Запуск скрипта не удался: destination
filesystem remount error". 
RAID контроллер: Intel Matrix RAID
HDD: WD10JUCT-63C 2шт
------- Comment #8 From 2015-03-04 16:56:51 -------
(В ответ на комментарий №7)
> RAID контроллер: Intel Matrix RAID
По возможности вытащите из инсталятора после такого сбоя файл /tmp/remount.log
и приложите к _отдельной_ баге, поставив меня в копию (с imsm известны
проблемы).

Такой fakeraid на данном этапе рекомендуется разобрать, если есть возможность
(не требуется dualboot и т.п.) -- и использовать контроллер как раздельные
каналы (каковыми он, по сути, и является).