Bug 2903 - need Requires(post,preun): apache ?
: need Requires(post,preun): apache ?
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/mod_ruby)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-08-30 19:54 by
Modified: 2008-02-15 22:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-08-30 19:54:49
when trying to remove apache (mod_ruby gets remocved, too):

The following packages will be REMOVED:
  apache apache-common apache-manual mod_php mod_ruby mod_ssl
[...]
warning: /etc/httpd/conf/ssl/ssl.default-vhost.conf saved as
/etc/httpd/conf/ssl/ssl.default-vhost.conf.rpmsave
E: Sub-process /bin/rpm returned an error code (255)

the last line was generated by mod_ruby %preun:

trickster:~> sudo rpm -e mod_ruby
/usr/bin/subst: open: /etc/httpd/conf/httpd.conf: No such file or directory
error: execution of %preun scriptlet from mod_ruby-1.0.6-alt1 failed, exit status 1

...or at least check the existence, or suppress exit code and stderr output.
------- Comment #1 From 2004-03-30 20:48:58 -------
я не собираюсь продолжать мантейнить mod_ruby.
------- Comment #2 From 2008-02-15 22:07:44 -------
re
------- Comment #3 From 2008-02-15 22:08:10 -------
apparently wontfix (it's not specific to mod_ruby btw)