Bug 29044 - explain that d3d9.dll needs an additional package
: explain that d3d9.dll needs an additional package
Status: NEW
: Sisyphus
(All bugs in Sisyphus/wine)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 29043
  Show dependency tree
 
Reported: 2013-06-02 04:39 by
Modified: 2013-06-02 04:39 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-06-02 04:39:45
wine-1.5.24-alt1

+++ This bug was initially created as a clone of Bug #29043 +++

+++ This bug was initially created as a clone of Bug #29042 +++

I was very confused with the problem with error message "Failed to load library
d3d9.dll".

Only after I looked into the "strace -fF -e trace=file wine ...." output, I
understood that d3d9.dll.so is missing from the wine libs.

Then, through http://search.altlinux.org and the spec file for the package, I
found out that this lib is in a separate package -- libwine-gl, which simply
has to be installed to cure the problem.

I believe there should be a more explicit explanation about this for the user.