Bug 29193 - nouveau E[ DRM] GPU lockup
: nouveau E[ DRM] GPU lockup
Status: NEW
: Sisyphus
(All bugs in Sisyphus/kernel-modules-drm-nouveau-un-def)
: unstable
: x86_64 Linux
: P3 normal
Assigned To:
:
: https://bugs.freedesktop.org/show_bug...
:
:
:
  Show dependency tree
 
Reported: 2013-07-17 09:55 by
Modified: 2015-08-05 05:42 (History)


Attachments
dmesg (71.25 KB, text/plain)
2013-07-17 09:55, ildar
no flags Details
Xorg.0.log (44.20 KB, text/plain)
2013-07-17 09:55, ildar
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-07-17 09:55:00
Created an attachment (id=5889) [details]
dmesg

Проявляется на DM, активно использующих GL (например, e17).



# lspci -vnn -s 01:00.0
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218M [NVS 3100M]
[10de:0a6c] (rev a2) (prog-if 00 [VGA controller])
    Subsystem: Lenovo ThinkPad T410 [17aa:2142]
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at cc000000 (32-bit, non-prefetchable) [size=16M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at ce000000 (64-bit, prefetchable) [size=32M]
    I/O ports at 2000 [size=128]
    [virtual] Expansion ROM at cd000000 [disabled] [size=512K]
    Capabilities: [60] Power Management version 3
    Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [78] Express Endpoint, MSI 00
    Capabilities: [b4] Vendor Specific Information: Len=14 <?>
    Capabilities: [100] Virtual Channel
    Capabilities: [128] Power Budgeting <?>
    Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
    Kernel driver in use: nouveau
------- Comment #1 From 2013-07-17 09:55:43 -------
Created an attachment (id=5890) [details]
Xorg.0.log
------- Comment #2 From 2013-07-17 10:01:04 -------
хотя по времени раньше происходит
[  2748.440] nouveau_exa_upload_to_screen:384 - falling back to memcpy ignores
tiling
[  2748.440] nouveau_exa_download_from_screen:299 - falling back to memcpy
ignores tiling
с последующим
  2748.440] (EE) Segmentation fault at address 0x0

я перепробовал 1.0.6 и 1.0.7 - то же самое (правда, на ядре std-def.
------- Comment #3 From 2014-02-03 06:27:19 -------
*** Bug 260998 has been marked as a duplicate of this bug. ***
Seen live from the domain http://volichat.com/adult-chat-rooms
Marked for reference. Resolved as fixed @bugzilla.
------- Comment #4 From 2015-08-05 05:42:38 -------
У меня на i686/std-pae таким образом X падает. И именно когда долго поработает
GL-приложение, в данном случае заставка xscreensaver-а.