Bug 29247 - [META] Ошибки и пожелания по Альт Линукс 7.0 Школьный
: [META] Ошибки и пожелания по Альт Линукс 7.0 Школьный
Status: NEW
: Школьный
(All bugs in Школьный/bugs)
: 7.0.2
: all Linux
: P3 normal
Assigned To:
:
: http://www.altlinux.org/Школьный/7.0
: METABUG
: 26944 29268 29269 29297 29592 29635 29700 29735
:
  Show dependency tree
 
Reported: 2013-07-31 14:42 by
Modified: 2014-08-26 17:21 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-07-31 14:42:18
Ошибки и пожелания по Информика 7.0 Школьный
------- Comment #1 From 2013-08-23 09:50:08 -------
freebasic нужен
см. требования КЕГЭ
http://forum.altlinux.org/index.php/topic,11990.msg188636.html#msg188636
для сборки пакета требуется сам freebasic
можно воспользоваться
http://ftp.linux.kiev.ua/pub/Linux/ALT/people/_kostyalamer/ALT_Linux_Club/repo_club/repo_p5school_update/i586/RPMS.hasher/freebasic-standalone-0.24.0-alt1.i586.rpm
------- Comment #3 From 2013-08-23 19:38:36 -------
Вот еще 
https://bugzilla.altlinux.org/show_bug.cgi?id=29297
------- Comment #6 From 2013-08-26 10:14:33 -------
с русификацией т.е.
------- Comment #7 From 2013-09-03 22:44:00 -------
А можно еще попросить новый qcad (чтоб не ломать старый может его как qcad3
назвать) и librecad 2 уже скоро релиз а в сизифе альфа
:)
------- Comment #8 From 2013-10-24 00:25:38 -------
(В ответ на комментарий №7)
> А можно еще попросить новый qcad (чтоб не ломать старый может его как qcad3
> назвать) и librecad 2 уже скоро релиз а в сизифе альфа
> :)

Вот qcad-3.4 появился
http://www.opennet.ru/opennews/art.shtml?num=38240
------- Comment #9 From 2013-10-25 10:05:55 -------
Используем дистрибутив в университете (Ивановский Государственный
Энергетический Университет). Просьба следующая - верните, пожалуйста,
возможность в KDevelop-е интеграцию с Perl! В 5-й версии была, а в 6-й вы ее
убрали. У нас студенты пишут на C++, PHP, Perl и Ruby. Кроме того, включите в
базовый набор пакетов Master-а модуль Perl-DBD-Mysql. Он занимает 10кб. Из-за
его отсутствия студенты не могут дома работать с live-dvd без установки со
связкой Apache-Perl-Mysql.
------- Comment #10 From 2013-11-05 12:31:38 -------
(В ответ на комментарий №7)
> А можно еще попросить новый qcad (чтоб не ломать старый может его как qcad3
> назвать) и librecad 2 уже скоро релиз а в сизифе альфа
> :)
Собираю librecad 2.0.0 rc2. qcad гальванизировать не будем, так как на него в
основных дистрибутвах забили. Там же и проблемы с кириллицей и отсутствием
свободной поддержки DWG.
------- Comment #11 From 2013-11-14 11:34:08 -------
(В ответ на комментарий №1)
> freebasic нужен
> см. требования КЕГЭ
> http://forum.altlinux.org/index.php/topic,11990.msg188636.html#msg188636
p7 Branch
freebasic-0.90.1-alt2.src.rpm
Sisyphus
freebasic-0.90.1-alt2.src.rpm

Собран сначала из бинарников, потом забутстраплен из исходников.
------- Comment #12 From 2013-11-14 15:25:06 -------
Страница по FreeBASIC в ALT Linux: http://www.altlinux.org/FreeBASIC
------- Comment #13 From 2013-11-21 21:49:34 -------
(В ответ на комментарий №11)
> freebasic-0.90.1-alt2.src.rpm
> freebasic-0.90.1-alt2.src.rpm


Спасибо!
------- Comment #14 From 2013-11-21 21:50:43 -------
(В ответ на комментарий №10)
qcad гальванизировать не будем, так как на него в
> основных дистрибутвах забили. Там же и проблемы с кириллицей и отсутствием
> свободной поддержки DWG.

Да :(
Про отсутствие локализации я что-то подзабыл... :( А для школы она нужна...
------- Comment #15 From 2013-11-21 22:04:45 -------
Тогда еще наберусь наглости и спрошу про bluegriffon (как замена композеру)
http://sources.disruptive-innovations.com/bluegriffon/trunk/langpacks/
вроде его почти русифицировали
:)
------- Comment #16 From 2013-11-22 10:18:04 -------
(В ответ на комментарий №15)
> Тогда еще наберусь наглости и спрошу про bluegriffon (как замена композеру)
> http://sources.disruptive-innovations.com/bluegriffon/trunk/langpacks/
> вроде его почти русифицировали
Я уже присматривался к нему, но сборка потребует довольно много трудозатрат. В
планах у меня стоит, но пока не горит.
------- Comment #17 From 2013-12-24 16:18:53 -------
Рекомендую добавить Logism. http://ru.wikipedia.org/wiki/Logisim Программа чаще
всего используется учащимися в курсе изучения информатики для разработки и
экспериментов с цифровыми схемами при моделировании. Схемы разрабатываются в
Logisim с помощью графического интерфейса, близкого к традиционному для
программ для рисования, такой интерфейс встречается во многих других программах
для моделирования схем. 
Интерфейс русский.
Скачать тут:
http://sourceforge.net/projects/circuit/
на java.
------- Comment #18 From 2013-12-25 23:35:37 -------
(В ответ на комментарий №17)
> Рекомендую добавить Logism. http://ru.wikipedia.org/wiki/Logisim Программа чаще

я для школьной 5ки переберал.
собиралась хорошо
http://ftp.linux.kiev.ua/pub/Linux/ALT/people/_kostyalamer/ALT_Linux_Club/repo_club/repo_p5school_update/SRPMS/logisim-2.7.1-1.mrc.mga2.src.rpm
http://ftp.linux.kiev.ua/pub/Linux/ALT/people/_kostyalamer/ALT_Linux_Club/repo_club/repo_p5school_update/i586/RPMS.hasher/logisim-2.7.1-1.mrc.mga2.noarch.rpm
------- Comment #19 From 2013-12-26 12:32:49 -------
(В ответ на комментарий №18)
> (В ответ на комментарий №17)
> > Рекомендую добавить Logism. http://ru.wikipedia.org/wiki/Logisim Программа чаще
> 
> я для школьной 5ки переберал.
> собиралась хорошо
#111044 BUILDING #1 [locked] sisyphus logisim.git=2.7.1-alt1
------- Comment #20 From 2013-12-26 12:49:58 -------
(В ответ на комментарий №9)
> верните, пожалуйста, возможность в KDevelop-е интеграцию с Perl! В 5-й версии 
> была, а в 6-й вы ее убрали.
Потому что в KDevelop 4.x такой поддержки нет и не планируется.
См. обсуждение на http://www.linux.org.ru/forum/development/8613909
------- Comment #21 From 2013-12-26 12:59:45 -------
(In reply to comment #20)
> > Потому что в KDevelop 4.x такой поддержки нет и не планируется.
Ясно. Жаль. Тогда хоть модуль (Perl-DBD-Mysql) в базовую поставку включите ;)
------- Comment #22 From 2013-12-26 16:38:57 -------
(В ответ на комментарий №21)
> (In reply to comment #20)
> > > Потому что в KDevelop 4.x такой поддержки нет и не планируется.
> Ясно. Жаль. Тогда хоть модуль (Perl-DBD-Mysql) в базовую поставку включите ;)

http://git.altlinux.org/people/cas/packages/mkimage-profiles-desktop.git?p=mkimage-profiles-desktop.git;a=commit;h=419400fd6c7734e70a936b25e0d4f128321bb488
------- Comment #23 From 2014-08-26 11:04:42 -------
Ребят, образ altlinux-7.0.3-school-master-x86_64-ru-install-dvd5.iso не лезет
ни на DVD-RW, ни на DVD+RW. Что с ним делать-то?
------- Comment #24 From 2014-08-26 17:21:09 -------
(В ответ на комментарий №23)
> Ребят, образ altlinux-7.0.3-school-master-x86_64-ru-install-dvd5.iso не лезет
> ни на DVD-RW, ни на DVD+RW. Что с ним делать-то?
Записывать на USB Flash. Инструкция: http://altlinux.org/Write