Bug 2954 - missing requires
: missing requires
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libImageMagick-devel)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-09-09 00:47 by
Modified: 2005-09-07 18:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-09-09 00:47:26
does not requires libexif-devel,freetype2-devel, but should
------- Comment #1 From 2003-09-09 01:06:21 -------
Зачем и почему ?
------- Comment #2 From 2003-09-09 02:13:38 -------
*** Bug 2955 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2003-09-10 22:08:37 -------
Все-таки стоит наверное сделать автоматическое средство для поиска подобных
зависимостей. 
------- Comment #4 From 2003-09-22 12:30:56 -------
fixed (5.5.7-alt3).

На будущее - пожалуйста, не модифицируйте мои спек-файлы самостоятельно.
Вы делаете ошибки, которые мне приходится исправлять (%exif_ver совсем не
обязателен, как и BuildPreReq на libexif-devel >= %exif_ver).
------- Comment #5 From 2003-09-22 15:11:45 -------
Я всеми силами старался не смотреть на ВАШ спецфайл, иначе бы перепахал его до
неузнаваемости ;-) И c exif_ver все правильно. Однако, я не настаиваю, меня
ждут
festival, gnome-peech, gnome-mag, gnopernicus и ....
------- Comment #6 From 2003-09-22 15:51:21 -------
я не понимаю - что правильного в exif_ver, если у libexif в любом случае
поменялся soname (.9) соответственно зависимость автоматически ляжет на ту
версию libexif, с которой происходит сборка.

В том же случае, если сборка идет в hasher, то достаточно предварительно в нем
же собрать libexif новой версии.