Bug 29628 - Прошу собрать версию 3.22.24.7 с исправлением множества уязвимостей
: Прошу собрать версию 3.22.24.7 с исправлением множества уязвимостей
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libv8-3.21)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-12-05 11:37 by
Modified: 2013-12-05 13:53 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-12-05 11:37:10
- Medium CVE-2013-6638: Buffer overflow in v8. This issue was fixed in v8
version 3.22.24.7.
- High CVE-2013-6639: Out of bounds write in v8. This issue was fixed in v8
version 3.22.24.7. 
- Medium CVE-2013-6640: Out of bounds read in v8. This issue was fixed in v8
version 3.22.24.7.
------- Comment #1 From 2013-12-05 13:41:26 -------
v8-3.22-3.22.24.8-alt1 -> sisyphus:

* Sun Dec 01 2013 Dmitriy Kulik <lnkvisitor@altlinux> 3.22.24.8-alt1
- new version (Closes: #29628)
  + Medium CVE-2013-6638: Buffer overflow in v8.
  + High CVE-2013-6639: Out of bounds write in v8.
  + Medium CVE-2013-6640: Out of bounds read in v8.

* Sun Dec 01 2013 Dmitriy Kulik <lnkvisitor@altlinux> 3.21.18.9-alt1
- new version

* Tue Oct 01 2013 Dmitriy Kulik <lnkvisitor@altlinux> 3.21.18.2-alt1.1
- fix arm build (sbolshakov@altlinux.ru)

* Sun Sep 29 2013 Dmitriy Kulik <lnkvisitor@altlinux> 3.21.18.2-alt1
- new version

* Tue Sep 17 2013 Dmitriy Kulik <lnkvisitor@altlinux> 3.21.16.2-alt1
- new version

* Tue Sep 17 2013 Dmitriy Kulik <lnkvisitor@altlinux> 3.20.17.7-alt1
- new version
------- Comment #2 From 2013-12-05 13:53:40 -------
Нужно тестировать. Начиная с 3.22 требуют ICU. Собрал с системным.