Bug 29642 - Неправильно работает звуковая карта компьютера модели HP xw4550
: Неправильно работает звуковая карта компьютера модели HP xw4550
Status: NEW
: Sisyphus
(All bugs in Sisyphus/kernel-image-std-def)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-12-09 14:47 by
Modified: 2013-12-10 19:46 (History)


Attachments
Вывод lspci -vv (11.55 KB, text/plain)
2013-12-09 14:49, Gennadij Redko
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-12-09 14:47:59
На 64-битной версии p7 не опознается и не работает правильно звуковая карта.
Вывод lspci -vv - во вложении.
Проявляется неработоспособность - в отсутствии некоторых регуляторов в
alsamixer, невоспроизведении звука в Amarok, отсутствии захвата звука с
микрофона в Skype.

Alsamixer опознает карту как Realtek ALC262

Какому модулю сопоставить багу не знаю - поставил alsa-utils.
Прошу переназначить.
------- Comment #1 From 2013-12-09 14:49:11 -------
Created an attachment (id=6000) [details]
Вывод lspci -vv
------- Comment #2 From 2013-12-09 16:10:41 -------
На Sisyphus.
------- Comment #3 From 2013-12-10 02:31:59 -------
Видимо, на kernel-image соответствующего вида; хорошо бы уточнить `uname -a`.

Также просьба по возможности проверить на led-ws -- удобнее всего поставить при
помощи update-kernel -t led-ws
------- Comment #4 From 2013-12-10 02:42:38 -------
$ uname -a
Linux host-218.localdomain 3.10.20-std-def-alt1 #1 SMP Thu Nov 21 10:05:06 UTC
2013 x86_64 GNU/Linux

Ядро подставлю попозже.
------- Comment #5 From 2013-12-10 02:47:05 -------
Ядро не ставится:
# update-kernel -t led-ws
Try to install new kernel kernel-image-led-ws-3.4.70-alt0.M70P.1 and update its
modules [y]/n? y
update-kernel: kernel-modules-drm is installed, trying to update...
update-kernel: kernel-modules-fglrx is installed, trying to update...
update-kernel: kernel-modules-kvm is installed, trying to update...
update-kernel: kernel-modules-nvidia is installed, trying to update...
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано kernel-modules-drm-led-ws#3.4.70-alt0.M70P.1 для
'kernel-modules-drm-3.4.70-led-ws-alt0.M70P.1'
Выбрано kernel-modules-fglrx-led-ws#13.20.16_3.4.70-alt0.M70P.1 для
'kernel-modules-fglrx-3.4.70-led-ws-alt0.M70P.1'
Выбрано kernel-modules-kvm-led-ws#3.10.1_3.4.70-alt0.M70P.1 для
'kernel-modules-kvm-3.4.70-led-ws-alt0.M70P.1'
Выбрано kernel-modules-nvidia-led-ws#319.72-alt1.197702.0.M70P.1 для
'kernel-modules-nvidia-3.4.70-led-ws-alt0.M70P.1'
Следующие дополнительные пакеты будут установлены:
  kernel-modules-drm-led-ws#3.4.70-alt0.M70P.1
kernel-modules-fglrx-led-ws#13.20.16_3.4.70-alt0.M70P.1
kernel-modules-kvm-led-ws#3.10.1_3.4.70-alt0.M70P.1
kernel-modules-nvidia-led-ws#319.72-alt1.197702.0.M70P.1 nvidia_glx_319.72
Следующие НОВЫЕ пакеты будут установлены:
  kernel-image-led-ws#3.4.70-alt0.M70P.1
kernel-modules-drm-led-ws#3.4.70-alt0.M70P.1
kernel-modules-fglrx-led-ws#13.20.16_3.4.70-alt0.M70P.1
kernel-modules-kvm-led-ws#3.10.1_3.4.70-alt0.M70P.1
kernel-modules-nvidia-led-ws#319.72-alt1.197702.0.M70P.1 nvidia_glx_319.72
0 будет обновлено, 6 новых установлено, 0 пакетов будет удалено и 281 не будет
обновлено.
Необходимо получить 32,4MB архивов.
После распаковки потребуется дополнительно 158MB дискового пространства.
Ошибка http://ftp.linux.kiev.ua x86_64/classic
kernel-image-led-ws#3.4.70-alt0.M70P.1 3.4.70-alt0.M70P.1
  404 Not Found
Ошибка http://ftp.linux.kiev.ua x86_64/classic
kernel-modules-drm-led-ws#3.4.70-alt0.M70P.1 3.4.70-alt0.M70P.1
  404 Not Found
Ошибка http://ftp.linux.kiev.ua x86_64/classic
kernel-modules-fglrx-led-ws#13.20.16_3.4.70-alt0.M70P.1
13.20.16_3.4.70-alt0.M70P.1
  404 Not Found
Ошибка http://ftp.linux.kiev.ua x86_64/classic
kernel-modules-kvm-led-ws#3.10.1_3.4.70-alt0.M70P.1 3.10.1_3.4.70-alt0.M70P.1
  404 Not Found
Получено: 1 http://ftp.linux.kiev.ua x86_64/classic nvidia_glx_319.72
319.72-alt120 [9322kB]
Ошибка http://ftp.linux.kiev.ua x86_64/classic
kernel-modules-nvidia-led-ws#319.72-alt1.197702.0.M70P.1
319.72-alt1.197702.0.M70P.1                                                     
  404 Not Found
Получено 9322kB за 6s (1518kB/s).                                               
Невозможно получить
http://ftp.linux.kiev.ua/pub/Linux/ALT/p7/branch/x86_64/RPMS.classic/kernel-image-led-ws-3.4.70-alt0.M70P.1.x86_64.rpm
 404 Not Found
Невозможно получить
http://ftp.linux.kiev.ua/pub/Linux/ALT/p7/branch/x86_64/RPMS.classic/kernel-modules-drm-led-ws-3.4.70-alt0.M70P.1.x86_64.rpm
 404 Not Found
Невозможно получить
http://ftp.linux.kiev.ua/pub/Linux/ALT/p7/branch/x86_64/RPMS.classic/kernel-modules-fglrx-led-ws-13.20.16_3.4.70-alt0.M70P.1.x86_64.rpm
 404 Not Found
Невозможно получить
http://ftp.linux.kiev.ua/pub/Linux/ALT/p7/branch/x86_64/RPMS.classic/kernel-modules-kvm-led-ws-3.10.1_3.4.70-alt0.M70P.1.x86_64.rpm
 404 Not Found
Невозможно получить
http://ftp.linux.kiev.ua/pub/Linux/ALT/p7/branch/x86_64/RPMS.classic/kernel-modules-nvidia-led-ws-319.72-alt1.197702.0.M70P.1.x86_64.rpm
 404 Not Found
E: Получить некоторые архивы невозможно. Попробуйте ввести команду apt-get
update или добавить параметр --fix-missing.                                     
update-kernel: failed to install kernel-image-led-ws-3.4.70-alt0.M70P.1 with
modules                                                                         
[root@host-218 ~]#
------- Comment #6 From 2013-12-10 02:55:11 -------
(В ответ на комментарий №5)
> Ядро не ставится:
Очевидно, apt-get update :)

> Try to install new kernel kernel-image-led-ws-3.4.70-alt0.M70P.1
Так они не спят, на ftp уже kernel-image-led-ws-3.4.72-alt0.M70P.1
------- Comment #7 From 2013-12-10 10:49:45 -------
Установил:
Linux host-218.localdomain 3.4.72-led-ws-alt0.M70P.1 #1 SMP PREEMPT Sat Dec 7
01:24:22 UTC 2013 x86_64 GNU/Linux

Звук пропал совсем.
Pulse Audio manager во вкладке устройств пишет  "Фиктивный выход" .
------- Comment #8 From 2013-12-10 13:35:11 -------
А, там же alsa отдельно -- поставьте kernel-modules-sound-led-ws
------- Comment #9 From 2013-12-10 14:31:34 -------
Да.
Появились регуляторы и переключатели от этой карты.
------- Comment #10 From 2013-12-10 17:10:45 -------
Тогда по крайней мере у Вас есть workaround. :)
------- Comment #11 From 2013-12-10 17:17:32 -------
Почему бага на Sisyphus, если рассказывается о проблемах в p7?
------- Comment #12 From 2013-12-10 18:38:33 -------
Как минимум сейчас в sisyphus и p7 сознательно поддерживаются копии std-def.
Вообще эту багу надо как-то внятно файлить на bugzilla.kernel.org, конечно.
------- Comment #13 From 2013-12-10 18:42:14 -------
(В ответ на комментарий №12)
> Вообще эту багу надо как-то внятно файлить на bugzilla.kernel.org, конечно.

Это если в 3.12 (или даже в 3.13) тоже не работает.
------- Comment #14 From 2013-12-10 18:50:07 -------
Кстати, да.  Геннадий, можете ещё на un-def проверить?
(хотя сломанный 3.10.x -- тоже повод для апстримной баги)
------- Comment #15 From 2013-12-10 19:46:04 -------
На:
3.12.2-un-def-alt1 #1 SMP PREEMPT Tue Dec 3 10:35:58 UTC 2013 x86_64 GNU/Linux

в alsamixer все движки и переключатели на  месте.
В Skype, правда, захват звука не работает, но он (Skype) как я понимаю не
поддерживается.