Bug 29846 - FR: новая версия 1.8.*
: FR: новая версия 1.8.*
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/subversion)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2014-02-24 19:59 by
Modified: 2015-08-22 10:36 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-02-24 19:59:13
Прошу обновить до 1.8.*
------- Comment #1 From 2015-07-24 18:01:22 -------
Добрый день. Присоединяюсь к просьбе собрать версию 1.8
Причина:
NetBeans >= 8.0
JavaHL client will work only with Subversion 1.8 checkouts
------- Comment #2 From 2015-07-27 12:25:03 -------
Хотелось бы уточнить, можно рассчитывать на  обновление пакета в ближайшем
обозримом будущем?
Или есть какие-то особые причины/проблемы из за которых он не обновляется?
------- Comment #3 From 2015-08-09 03:01:15 -------
можно проверить на Sisyphus сборку 1.9.0:

apt-repo add 147031
apt-get update
apt-get dist-upgrade
------- Comment #4 From 2015-08-13 09:29:53 -------
При попытке сделать checkout ругается:

svn checkout https://svn.somehost.ru/svn/project
svn: E170000: Unrecognized URL scheme for 'https://svn.somehost.ru/svn/project'
------- Comment #5 From 2015-08-19 22:58:13 -------
(В ответ на комментарий №4)
> При попытке сделать checkout ругается:
> 
> svn checkout https://svn.somehost.ru/svn/project
> svn: E170000: Unrecognized URL scheme for 'https://svn.somehost.ru/svn/project'
Решил собрать 1.8.13. Прошу проверить (с удалением 1.9, конечно):

apt-repo add 147891
apt-get update
apt-get install subversion
------- Comment #6 From 2015-08-19 23:28:24 -------
> Решил собрать 1.8.13. Прошу проверить (с удалением 1.9, конечно):

1.9 я давно уже снес.
Проверил. Та же самая ошибка - абсолютно идентичный код ошибки и текст.
Предполагаю, что может быть какой-то модуль, который отвечает за работу клиента
svn по протоколу https отключен при сборке. 
У меня кстати тогда 1.8 не собралась - прошли тесты - долго шли - а потом
сломалось при упаковке в RPM уже, если я правильно  понял диагностику.
------- Comment #7 From 2015-08-19 23:38:28 -------
Вот вывод от 1.7:
svn --version
svn, version 1.7.8 (r1419691)
   compiled Dec 12 2014, 00:17:40

Copyright (C) 2012 The Apache Software Foundation.
This software consists of contributions made by many people; see the NOTICE
file for more information.
Subversion is open source software, see http://subversion.apache.org/

The following repository access (RA) modules are available:

* ra_neon : Module for accessing a repository via WebDAV protocol using Neon.
  - handles 'http' scheme
  - handles 'https' scheme
* ra_svn : Module for accessing a repository using the svn network protocol.
  - handles 'svn' scheme
* ra_local : Module for accessing a repository on local disk.
  - handles 'file' scheme

А в выводе svn --version для 1.8.13 ra_neon отсутствовал.
------- Comment #8 From 2015-08-20 13:20:19 -------
>А в выводе svn --version для 1.8.13 ra_neon отсутствовал.
Может для этого какая-нибудь отдельная опция для сборки нужна?
------- Comment #9 From 2015-08-21 01:24:38 -------
(В ответ на комментарий №7)
> А в выводе svn --version для 1.8.13 ra_neon отсутствовал.
Потому что апстрим перешёл на libserif, который у нас не собран:

* ra_serf : Module for accessing a repository via WebDAV protocol using serf.
  - using serf 1.3.8
  - handles 'http' scheme
  - handles 'https' scheme

Я уже взял из Fedora и пересобрал. Прошу прове
------- Comment #10 From 2015-08-21 01:25:58 -------
Прошу проверить задание 147891
------- Comment #11 From 2015-08-21 15:16:21 -------
subversion-1.8.13-alt1 -> sisyphus:

* Mon Aug 03 2015 Andrey Cherepanov <cas@altlinux> 1.8.13-alt1
- New version 1.8.13 (ALT #29846)
------- Comment #12 From 2015-08-21 20:06:38 -------
(В ответ на комментарий №10)
> Прошу проверить задание 147891

Стал проверять задание, но видимо опоздал....

Пропущено http://git.altlinux.org x86_64/task release
Ошибка http://git.altlinux.org x86_64-i586/task pkglist
  404 Not Found
Пропущено http://git.altlinux.org x86_64-i586/task release
Невозможно получить
http://git.altlinux.org/repo/147891/x86_64/base/pkglist.task  404 Not Found
Невозможно получить
http://git.altlinux.org/repo/147891/x86_64-i586/base/pkglist.task  404 Not
Found
Чтение списков пакетов... Завершено
------- Comment #13 From 2015-08-22 10:36:41 -------
Проверил из сизифа. 
Новый проект зачекаутился, старый проект в новый формат сконвертился.
javahl с Netbeans работает.