Bug 29884 - Обновление до 1.0.46 поломало печать (Filter failed)
Summary: Обновление до 1.0.46 поломало печать (Filter failed)
Status: CLOSED FIXED
Alias: None
Product: Sisyphus
Classification: Development
Component: cups-filters (show other bugs)
Version: unstable
Hardware: all Linux
: P3 normal
Assignee: Anton Farygin
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-12 14:36 MSK by Eugene Vlasov
Modified: 2014-03-12 21:54 MSK (History)
2 users (show)

See Also:


Attachments
Лог ошибок (пробная страница cups) (10.92 KB, application/octet-stream)
2014-03-12 14:36 MSK, Eugene Vlasov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Vlasov 2014-03-12 14:36:46 MSK
Created attachment 6055 [details]
Лог ошибок (пробная страница cups)

После обновления cups-filters до 1.0.46-alt1 печать останавливается с сообщением об ошибке "Filter failed", удаление принтера и повторное добавление не помогает. В логе ошибок cups такое:

D [12/Mar/2014:15:14:52 +0600] [Job 1021] gs: No such file or directory

Может проблема не в этом, но с предыдущей версией фильтров такой ошибки нет, полную версию лога по этому заданию добавляю во вложения. /usr/bin/gs на месте, естественно.
$ rpm -qa | grep ghostscript | sort
ghostscript-9.10-alt2
ghostscript-classic-9.10-alt2
ghostscript-common-9.10-alt2
ghostscript-module-X-9.10-alt2
ghostscript-utils-9.10-alt2

После отката cups-filters до 1.0.41-alt2 и пересоздания принтера печать работает нормально.

Принтер EPSON L350 с проприетарными драйверами, скачанными с epson.net (epson-inkjet-printer-201207w-1.0.0).

$ uname -a
Linux eugene-home.ikz.ru 3.10.30-std-def-alt1 #1 SMP Fri Feb 14 10:33:49 UTC 2014 x86_64 GNU/Linux

$ rpm -qa | grep cups | sort
cups-1.7.0-alt2
cups-filters-1.0.46-alt1
cups-filters-libs-1.0.46-alt1
docs-print_cups-0.1-alt2
hplip-hpcups-3.13.9-alt2
hplip-hpcups-PPDs-3.13.9-alt2
i586-libcups-1.7.0-alt2
libcups-1.7.0-alt2
libcups-devel-1.7.0-alt2
libgnomecups-0.2.3-alt5
python-module-cups-1.9.62-alt1
python-module-cupshelpers-1.3.13-alt2
Comment 1 Anton Farygin 2014-03-12 14:43:52 MSK
Сейчас поправлю в 1.0.47
Comment 2 Repository Robot 2014-03-12 21:54:14 MSK
cups-filters-1.0.47-alt1 -> sisyphus:

* Wed Mar 12 2014 Anton Farygin <rider@altlinux> 1.0.47-alt1
- new version with security fixes: CVE-2013-6474, CVE-2013-6475,
  CVE-2013-6476 and CVE-2013-6473
- fixed ghostscript path (closes: #29884)