Bug 29908 - Добавить provides: cups-libs
: Добавить provides: cups-libs
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/cups)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 30473
  Show dependency tree
 
Reported: 2014-03-26 01:50 by
Modified: 2014-11-14 20:51 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-03-26 01:50:48
Для совместимости с rpm-пакетами для других rpm-систем (в частности, для
пакетов с драйверами для принтеров Xerox) предлагаю добавить в пакет cups
Provides: cups-libs = %version

Судя по содержимому пакета, ему более нужен cups, чем libcups:
# rpm -ql Xerox-Phaser-3010_3040-1.0-28
/usr/lib/cups/filter
/usr/lib/cups/filter/xrhr1ap
/usr/lib/cups/filter/xrhr2ap
/usr/lib/xrhr1acl.so
/usr/share/cups/Xerox
/usr/share/cups/Xerox/dlut
/usr/share/cups/Xerox/dlut/xrhr1alut.dat
/usr/share/cups/model/Xerox
/usr/share/cups/model/Xerox/Xerox-Phaser-3010-fr.ppd.gz
/usr/share/cups/model/Xerox/Xerox-Phaser-3010.ppd.gz
/usr/share/cups/model/Xerox/Xerox-Phaser-3040-fr.ppd.gz
/usr/share/cups/model/Xerox/Xerox-Phaser-3040.ppd.gz
------- Comment #1 From 2014-04-21 14:32:47 -------
cups-1.7.2-alt1 -> sisyphus:

* Mon Apr 21 2014 Fr. Br. George <george@altlinux> 1.7.2-alt1
- Version up
- Previous version unreleased, so autoclose bugs again
- (closes: #29910, #29445, #29908)

* Wed Apr 16 2014 Fr. Br. George <george@altlinux> 1.7.1-alt1
- Version up (closes: #29910, #29445)
- Compatibility provide: cups-libs (closes: #29908)
- FC and Ubuntu patchset update
- Add post_service/preun_service