Bug 30015 - Для воспроизведения мультимедиа добавить в зависимость gst-libav
: Для воспроизведения мультимедиа добавить в зависимость gst-libav
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/LibreOffice4)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2014-04-19 08:46 by
Modified: 2015-02-11 14:12 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-04-19 08:46:15
При вставке большинства видео-файлов видео не проигрывается, присутствует
только звук.
Можно пробовать этот файл
http://ftp.linux.kiev.ua/pub/media/video/favorites.avi, он также не
вставляется.

Порядок действий.
Выбираю третий макет и на слайде нажимаю "Вставить видео". Libre очень сильно
подумает, прежде чем вставить файл, при этом ЦПУ не нагружает. После
"подвисания" видео всё же вставляется, звук играет, картинки нет. Некоторые
файлы вообще не вставляет, либо нужно ждать дольше..., а некоторые просто
никакой реакции после нажатия вставить...
(http://forum.altlinux.org/index.php/topic,32325.msg227369.html#msg227369)

Но, установил ту же версию от Libre из rpm — звук и видео играют без проблем.
http://forum.altlinux.org/index.php/topic,32325.msg227910.html#msg227910

Хотелось бы найти виновника.
Спасибо.
------- Comment #1 From 2014-04-27 17:26:51 -------
В libreoffice-3.6.5.2 (p6) favorites.avi вставляется быстро, и, хотя на
предпросмотре показывается с вопросом, воспроизводится без проблем.

Думаю, проблема в сборке с кривым новым gstreamer1.0, так как с gstreamer-0.10
всё работает. Надо проверять нашу сборку gst-plugin-* на воспроизведение
favorites.avi.

Перевешиваю на Sisyphus.
------- Comment #2 From 2014-04-27 17:32:36 -------
Похоже, нам нужен собранный из
http://gstreamer.freedesktop.org/modules/gst-libav.html пакет аналогичный
https://packages.debian.org/ru/sid/gstreamer1.0-libav.
------- Comment #3 From 2014-04-27 17:33:56 -------
Прошу прощения за чат, он у нас уже собран. Установите пакет gst-libav и
проверьте.
------- Comment #4 From 2014-04-27 20:18:49 -------
(В ответ на комментарий №3)
> Прошу прощения за чат, он у нас уже собран. Установите пакет gst-libav и
> проверьте.

Да, после установки gst-libva, видео вставляется нормально.
------- Comment #5 From 2014-04-28 07:20:36 -------
(В ответ на комментарий №4)
> gst-libva

*gst-libav
------- Comment #6 From 2014-04-28 10:03:29 -------
(В ответ на комментарий №4)
> Да, после установки gst-libav, видео вставляется нормально.
Сдаётся мне, что зависимости на gst-plugins-*1.0 надо заменить на одну -
gst-libav (которая поддерживает 40+ форматов). Гоша, что скажешь?
------- Comment #7 From 2014-04-28 11:41:00 -------
https://bugzilla.altlinux.org/show_bug.cgi?id=30041 заодно ещё, пожалуйста.
Спасибо!
------- Comment #8 From 2014-04-28 19:06:06 -------
(В ответ на комментарий №6)
> Сдаётся мне, что зависимости на gst-plugins-*1.0 надо заменить на одну -
> gst-libav (которая поддерживает 40+ форматов). Гоша, что скажешь?

Вот новый выйдет, потестим с этой зависимостью?
------- Comment #9 From 2014-04-29 12:00:15 -------
(В ответ на комментарий №8)
> (В ответ на комментарий №6)
> > Сдаётся мне, что зависимости на gst-plugins-*1.0 надо заменить на одну -
> > gst-libav (которая поддерживает 40+ форматов). Гоша, что скажешь?
> 
> Вот новый выйдет, потестим с этой зависимостью?
Да.
------- Comment #10 From 2015-02-11 14:12:45 -------
LibreOffice4-4.4-alt1 -> sisyphus:

* Thu Feb 05 2015 Fr. Br. George <george@altlinux> 4.4-alt1
- Update to 4.4.0.3
- Turn tt and be langpacks on

* Mon Dec 01 2014 Fr. Br. George <george@altlinux> 4.3-alt3
- Update to 4.3.5.1

* Wed Nov 19 2014 Fr. Br. George <george@altlinux> 4.3-alt2
- Update to 4.3.4.1

* Wed Nov 12 2014 Fr. Br. George <george@altlinux> 4.3-alt1
- Update to 4.3.3.2
- Provide loffice binary (Closes: #30044)
- Reqiure gst-libav (Closes: #30015)