Bug 3016 - buildreq: "terminfo-extra" is included sometimes
: buildreq: "terminfo-extra" is included sometimes
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm-utils)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-09-21 23:14 by
Modified: 2005-07-13 15:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-09-21 23:14:36
The compiltaion process may use the terminfo database, and so the generated list
of dependencies may include "terminfo-extra" if buildreq was called from a rare
terminal.

Simply automatically ignoring this dependency may not be the right thing, since
it is possible that the terminfo data is really required to build the package.

Perhaps, setting TERM to a simple value ("dumb") is a solution...


Packages involved:

$ rpm -qa rpm-utils terminfo-extra 'color*'
rpm-utils-0.7.0-alt1
terminfo-extra-5.3.20021019-alt1
color-gcc-0.6.0-alt2
colorifer-0.6.0-alt2


Steps to Reproduce:
The info for the terminal type of Emacs' shell/term is in terminfo-extra. Here
is how it gets into BuildReq's:

1. install terminfo-extra
2. emacs, M-x eshell RET
3. export TERM=eterm # "eterm" means Emacs' term
4. buildreq urlview.spec

Actual Results:  
# Automatically added by buildreq on Sun Sep 21 2003
BuildRequires: OpenSP libncurses-devel libtinfo-devel sgml-tools terminfo-extra


Expected Results:  
# Automatically added by buildreq on Sun Sep 21 2003
BuildRequires: OpenSP libncurses-devel libtinfo-devel sgml-tools
------- Comment #1 From 2003-09-22 00:42:56 -------
Since hasher (more exactly, hasher-priv) defines TERM=dumb, probably packagereq
may do 
the same without risk of break. 
------- Comment #2 From 2003-09-22 18:46:02 -------
Implemented in -0.7.1-alt1