Bug 3024 - Library mjpegutils doesn't exists
: Library mjpegutils doesn't exists
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mjpegtools-devel)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-09-22 15:10 by
Modified: 2005-07-13 15:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-09-22 15:10:11
[mouse@mouse]$ mjpegtools-config --libs
-lmjpegutils

[mouse@mouse]$ rpm -ql mjpegtools-devel|grep mjpegutils|wc -l
0

only mjpegtools-devel-libs have mjpegutils static lib: ls mjpegtools-* | xargs
rpm -qlp | grep mjpegutils
/usr/lib/libmjpegutils.a

version is 1.6.1.90-alt1
------- Comment #1 From 2003-09-22 16:32:55 -------
1) package mjpegtools-devel-libs doesn't exist (see your bug description)
2) only static version of libmjpegutils exists.
3) not a bug, see XFree86-static-libs for example.
------- Comment #2 From 2003-09-22 17:06:08 -------
You must add requires for mjpegtools-static-libs or add mjpegutils shared lib to
mjpegtools-devel if it possible.
------- Comment #3 From 2003-09-22 18:04:49 -------
$ rpm -qp --lastchange mjpegtools-1.6.1.90-alt2.src.rpm
* Пнд Сен 22 2003 Yuri N. Sedunov <aris@altlinux.ru> 1.6.1.90-alt2

- mjpegtools-devel requires mjpegtools-static-libs (fix #3024).