Bug 3050 - buildreq не цепляет зависимость на libpam-devel
: buildreq не цепляет зависимость на libpam-devel
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm-utils)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-09-26 16:37 by
Modified: 2007-04-06 16:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-09-26 16:37:58
buildreq не цепляет зависимость на libpam0-devel, и в итоге получается вот
такая
ошибка:
./drakxtools-1.1.7-alt28.i586.rpm: invalid dependencies:
pam%{_pam_name_suffix}(system-auth) pam_permit.so%{_pam_so_suffix}
pam_rootok.so%{_pam_so_suffix} pam_xauth.so%{_pam_so_suffix}
pam%{_pam_name_suffix}(net_monitor)
./drakxtools-http-1.1.7-alt28.i586.rpm: invalid dependencies:
pam%{_pam_name_suffix}(system-auth) pam%{_pam_name_suffix}(miniserv)
ERROR: you have problems with package dependencies

Очень неприятно ;-(
------- Comment #1 From 2003-09-26 16:44:49 -------
Не только на libpam0-devel, но и на libpam2-devel. 
Сегодня оба будут пересобраны. 
 
Скажи спасибо sisyphus_check'у, что поймал. 
------- Comment #2 From 2003-09-26 19:26:31 -------
Fixed in 
libpam0-devel-0.75-alt23 
libpam2-devel-20030715-alt2 
 
Use "buildreq -bi" from rpm-utils >= 0.7.3-alt1 
 
------- Comment #3 From 2003-09-27 18:16:51 -------
Latest fix was wrong. 
Really fixed in rpm-build-4.0.4-alt26