Bug 3053 - kernel-headers-std breaks build of two essential packages
: kernel-headers-std breaks build of two essential packages
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-headers-std-up)
: unstable
: all Linux
: P3 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-09-26 20:01 by
Modified: 2005-09-05 03:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-09-26 20:01:20
kernel-headers-std-* >= 2.4.22 breaks build of following essential packages: 
iproute2-2.4.7-alt5.ss010824 
iputils-20020927-alt2 
 

Steps to Reproduce:
Just try to rebuild one of these packages in hasher. 
Actual Results:  
Compilation stops due to errors: 
 
gcc -pipe -Wall -O2 -march=i586 -mcpu=i686 -D_GNU_SOURCE -Wstrict-prototypes 
-Iinclude-glibc -include include-g 
libc/glibc-bugs.h -I/etc/sysconfig/kernel/include -I../include     -c -o tracepath.o 
tracepath.c 
In file included from include-glibc/netinet/in.h:7, 
                 from /usr/include/netdb.h:28, 
                 from tracepath.c:19: 
/etc/sysconfig/kernel/include/linux/in.h:140: field `gr_group' has incomplete type 
/etc/sysconfig/kernel/include/linux/in.h:146: field `gsr_group' has incomplete type 
/etc/sysconfig/kernel/include/linux/in.h:147: field `gsr_source' has incomplete type 
/etc/sysconfig/kernel/include/linux/in.h:153: field `gf_group' has incomplete type 
/etc/sysconfig/kernel/include/linux/in.h:156: field `gf_slist' has incomplete type 
make: *** [tracepath.o] Error 1 
 

Expected Results:  
Both packages should build cleanly.
------- Comment #1 From 2003-09-30 14:36:46 -------
Both builds with kernel-headers-std-up-2.4.22-alt5 
------- Comment #2 From 2003-09-30 14:47:38 -------
Both build with kernel-headers-std-up-2.4.22-alt5