Bug 30543 - gPodder не запускается из-за ошибок
: gPodder не запускается из-за ошибок
Status: CLOSED WONTFIX
: Branch p7
(All bugs in Branch p7/gpodder)
: не указана
: x86_64 Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2014-12-06 10:46 by
Modified: 2018-02-28 17:26 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-12-06 10:46:46
Версия программы 3.1.2

Вывод в эмуляторе терминала:
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading
configurations from ~/.fonts.conf is deprecated. please move it to
/home/dima/.config/fontconfig/fonts.conf manually
1417851880.753263 [gpodder.log] ERROR: Uncaught exception: Traceback (most
recent call last):
  File "/usr/bin/gpodder", line 175, in <module>
    main()
  File "/usr/bin/gpodder", line 170, in main
    main.main(options)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 3433, in
main
    gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model))
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 117, in
__init__
    BuilderWidget.__init__(self, None)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/common.py",
line 38, in __init__
    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain,
**kwargs)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/base.py", line 66, in
__init__
    self.new()
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 207, in
new
    self.channels = self.model.get_podcasts()
  File "/usr/lib/python2.7/site-packages/gpodder/model.py", line 1375, in
get_podcasts
    self.children = self.db.load_podcasts(podcast_factory)
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 156, in
load_podcasts
    cur = self.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 100, in
cursor
    return self.db.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 94, in db
    schema.upgrade(self._db, self.database_file)
  File "/usr/lib/python2.7/site-packages/gpodder/schema.py", line 170, in
upgrade
    raise Exception('Database schema version unknown')
Exception: Database schema version unknown

Traceback (most recent call last):
  File "/usr/bin/gpodder", line 175, in <module>
    main()
  File "/usr/bin/gpodder", line 170, in main
    main.main(options)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 3433, in
main
    gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model))
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 117, in
__init__
    BuilderWidget.__init__(self, None)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/common.py",
line 38, in __init__
    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain,
**kwargs)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/base.py", line 66, in
__init__
    self.new()
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 207, in
new
    self.channels = self.model.get_podcasts()
  File "/usr/lib/python2.7/site-packages/gpodder/model.py", line 1375, in
get_podcasts
    self.children = self.db.load_podcasts(podcast_factory)
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 156, in
load_podcasts
    cur = self.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 100, in
cursor
    return self.db.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 94, in db
    schema.upgrade(self._db, self.database_file)
  File "/usr/lib/python2.7/site-packages/gpodder/schema.py", line 170, in
upgrade
    raise Exception('Database schema version unknown')
Exception: Database schema version unknown
------- Comment #1 From 2018-02-28 17:26:56 -------
В p8 версия 3.9.3-alt1 запускается. Закрываю баг.