Bug 3082 - 20030926: several ERRORS regarding NVIDIA setup
: 20030926: several ERRORS regarding NVIDIA setup
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/Compact-2.3-beta)
: unstable
: all Linux
: P1 blocker
Assigned To:
:
:
:
:
: 3005
  Show dependency tree
 
Reported: 2003-09-30 22:37 by
Modified: 2005-08-03 23:14 (History)


Attachments
fix nvidia glx in usr/bin/perl-install/Xconfigurator.pm (676 bytes, patch)
2003-10-26 20:48, Michael Shigorin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-09-30 22:37:03
1) installer would yield broken /etc/X11/XF86Config-4 with:
    Load "glx"
instead of proper
    Load "/usr/X11R6/lib/modules/extensions/libglx.so"
(with additional warning on exactly this topic within comments)

(rider: need to fix this back ASAP!)

2) see community-en@ (Sep 30, 2003, From: Kalajan):

> Well I show the console log (alt+F3) and the installation no
> found "vidia_glx_1.0.4496" but the real name of package is
> "nvidia_glx_1.0.4496" (exactly
> nvidia_glx_1.0.4496-1.0.4496-alt5.i586.rpm). 
> I other system a search this error in the CD files and it was
> found in Xconfigurator.pm (in the path
> /ALTLinux/mdkinst/usr/bin/perl-install/) that had writed
> "vidia_glx_1.0.4496" and not "nvidia_glx_1.0.4496".

Thus a Fatal Typo (TM)
------- Comment #1 From 2003-10-01 12:31:31 -------
1) - this options need only for nvidia driver.. fixed
2) fixed (compact-20030930.iso, coming soon)
------- Comment #2 From 2003-10-01 12:37:03 -------
re 1) ("only") -- sure, but it was working :-)
re 2) -- great :)
------- Comment #3 From 2003-10-07 03:30:40 -------
(1) ни разу не fixed в installer-20031005.  Это даже не blocker, а еще
ступенькой хуже.

(2) сейчас проверю.
------- Comment #4 From 2003-10-22 15:14:36 -------
Замечается на GF2, _не_ замечается на TNT2/TNT2 Vanta.  Видимо, "зацепка" в
строках, на которые реагируем... (последний раз пробовал на compact-20031008, в
1010 это вроде не трогалось) 
------- Comment #5 From 2003-10-26 20:48:23 -------
Created an attachment (id=304) [details]
fix nvidia glx in usr/bin/perl-install/Xconfigurator.pm

Прилагается патч (и получившийся Xconfigurator.pm) для инсталятора, с
которым обеспечивается гарантированное прописывание правильной 
строчки для libglx.so в XF86Config-4.

Проблема с одной из карт в моем распоряжении была в том, что для
нее выставлялся флажок DRI_glx, который в этом фрагменте 
отрабатывался первым. (вообще говоря, она еще и возвращает не 
[nN]Vidia, а NVIDIA -- но соотв. изменение регэксов с добавлением
флажка /i никак не повлияло на ситуацию, поэтому есть подозрение,
что корень проблемы -- где-то в мусоре в Cards+, приводящем к 
выставлению DRI, что неверно).
------- Comment #6 From 2003-10-27 18:51:49 -------
fixed (20031027.iso)