Bug 31 - keytable initscript redirects all its output to a wrong place (the physical console)
: keytable initscript redirects all its output to a wrong place (the physical c...
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/console-tools)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2001-09-29 19:33 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2001-09-29 19:33:04
There is a command like `action loadkeys ... > /dev/tty0 < /dev/tty0\'
in /etc/init.d/keytable (start/restart function). /dev/tty0 is meant
to be the terminal for loadkeys (it should load the keymaps to a
physical console), but due to an error in the statement the hwole
output of action function goes there (the OK or FAILED msgs).

This is not critical since service keytable is usually started only
during boot-up, so the output goes to the right place.
>How-To-Repeat:
        <code/input/activities to reproduce the problem (multiple
lines)>
$ ssh mymachine
# sudo service keytable restart

-- and you will see neither OK\'s  or FAILED\'s. There can be found
here: cat /dev/vcs. (So you have spoilt the console where another
person might be working.)
---

---
smth like bash -c \"loadkeys .. < .. > ...\"

------- Comment #1 From 2002-01-01 22:52:15 -------
Fixed in console-tools-0.2.3-ipl9mdk (Linux Progress bar depends on this fix.)
------- Comment #2 From 2002-01-01 22:52:15 -------
Fixed in console-tools-0.2.3-ipl9mdk (Linux Progress bar depends on this fix.)