Bug 31037 - не работоспособный пакет postgrey
: не работоспособный пакет postgrey
Status: ASSIGNED
: Sisyphus
(All bugs in Sisyphus/postgrey)
: unstable
: x86_64 Linux
: P3 normal
Assigned To:
:
:
: backport
:
:
  Show dependency tree
 
Reported: 2015-05-29 12:11 by
Modified: 2016-03-22 23:09 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2015-05-29 12:11:52
service postgrey start
Starting postgrey service: Can't locate Pod/Text.pm in @INC (@INC contains:
/usr/local/lib64/perl/5.16 /usr/local/share/perl/5.16 /usr/lib64/perl5
/usr/share/perl5 /usr/lib64/perl5 /usr/share/perl5 /etc/perl5
/usr/lib/perl5/vendor_perl) at (eval 1) line 2.
BEGIN failed--compilation aborted at /usr/share/perl5/Pod/Usage.pm line 29.
Compilation failed in require at /usr/sbin/postgrey line 12.
BEGIN failed--compilation aborted at /usr/sbin/postgrey line 12.ъ

Связана она с модулем 
 pod2usage
Can't locate Pod/Text.pm in @INC (@INC contains: /usr/local/lib64/perl/5.16
/usr/local/share/perl/5.16 /usr/lib64/perl5 /usr/share/perl5 /usr/lib64/perl5
/usr/share/perl5 /etc/perl5 /usr/lib/perl5/vendor_perl .) at (eval 1) line 2.
BEGIN failed--compilation aborted at /usr/share/perl5/Pod/Usage.pm line 29.
Compilation failed in require at /usr/bin/pod2usage line 128.
------- Comment #1 From 2015-06-02 17:54:58 -------
Битая зависимость - всего лишь нужно было установить perl-Pod-Spell (вместо
perl-Pod-Text которого нет).
------- Comment #2 From 2015-06-02 18:15:53 -------
На Sisyphus
------- Comment #3 From 2016-03-22 23:09:04 -------
В новом postgrey умолчания такие:
         --whitelist-clients=FILE     default:
/etc/postfix/postgrey_whitelist_clients
         --whitelist-recipients=FILE  default:
/etc/postfix/postgrey_whitelist_recipients

А соотв. файлы лежат в /etfc/postgrey

Запускаться отказывается с ошибкой
FATAL: ERROR: can't open lock file: /var/spool/postfix/postgrey/postgrey.lock


P.S.
Я уж молчу, что у меня почему-то /sbin/service удаляется всё время :)