Bug 3140 - libnullplugin.so is better to be in separete package
: libnullplugin.so is better to be in separete package
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/mozilla)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-10-10 13:32 by
Modified: 2005-07-13 15:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-10-10 13:32:10
Было бы очень удобно, если бы файл /usr/lib/mozilla/plugins/libnullplugin.so
находился в отдельном пакете и от него не зависела бы остальная mozilla. При
неустановленном flash player и отсутствии желания его устанавливать, назойливое
предложение установить его утомляет.
------- Comment #1 From 2004-05-05 16:27:06 -------
подарок новому мантейнеру 
------- Comment #2 From 2004-06-03 16:04:25 -------
Так удалите /usr/lib/mozilla/plugins/libnullplugin.so сами если хотите, но не 
устанавливать этот файл нельзя т.к. обычному пользователю он будет нужен 
по умолчанию.
------- Comment #3 From 2004-06-03 16:13:55 -------
Ага, и удалять его после каждого обновления мозиллы. Очень приятное занятие на
нескольких машинах. ИМХО mozilla-psm куда как необходимее и полезнее обычному
пользователю, но он пакуется в отдельный пакет и ничего страшного в этом нет. А
от /usr/lib/mozilla/plugins/libnullplugin.so как раз пользы обычному
пользователю ALT пользы ИМХО никакой, так как flash plugin ему лучше поставить
через apt из дистрибутива, а не с сайта макромедии.
------- Comment #4 From 2004-06-03 17:08:49 -------
libnullplugin может предлагать установить не только flush ... но и те плагины, 
которых у нас в сизифе нет. Это нужный плагин.
------- Comment #5 From 2004-06-03 17:12:59 -------
Так я же не предлагаю от него отказаться совсем! Я предлагаю паковать его
отдельно с разумным описанием. ИМХО ситуация когда для обеспечения
функциональности (отсутствие надоедливого окошка) надо удалять бинарник
принадлежащий пакету ненормальна. Может у народа спросим? ;)
------- Comment #6 From 2004-06-03 17:32:32 -------
Я могу этот плагин запаковать отдельно, но mozilla будет его требовать. Я еще
раз 
говорю, что я считаю его необходимым при начальной установке. 
Если вам не нравится постоянные предложения установить flush plugin вы можете:
1) удалить nullplugin
2) установить flush plugin
3) не открывать сайты написанные с использованием flush
4) терпеть.
Мне кажется достаточно большая свобода для выбора.
------- Comment #7 From 2004-06-03 17:36:28 -------
Если будет требовать -- это не имеет смысла. Вообще никакого. Дело ваше, вы
ответственный, но тогда уж лучше  mozilla-psm требовать -- от него уж точно
польза есть.