Bug 31480 - shell-getopt: невозможно использовать --opt при наличии opt-something
: shell-getopt: невозможно использовать --opt при наличии opt-something
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libshell)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2015-11-12 20:15 by
Modified: 2015-11-24 16:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2015-11-12 20:15:05
$ gear-import --tag=v1.34 --subdir=fossil ~/download/fossil-src-1.34.tar.gz
gear-import: option '--tag=v1.34' is ambiguous; possibilities: '--tag'
'--tag-message'

Нет тут никакой неоднозначности.
------- Comment #1 From 2015-11-24 16:48:51 -------
libshell-0.4.1-alt1 -> sisyphus:

* Tue Nov 24 2015 Alexey Gladkov <legion@altlinux> 0.4.1-alt1
- New version (0.4.1).
- shell-ini-config changes:
  + Return error if config file does not exist (ALT#31151).
- shell-getopt changes:
  + Fix getopt option completion (ALT#31480).