Bug 31531 - Ошибка установки пакета postgresql9.4-1C-server из-за конфликта пакетов libpq5.7-1C и libpq5.7
: Ошибка установки пакета postgresql9.4-1C-server из-за конфликта пакетов libpq...
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/postgresql9.4-1C-server)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2015-11-24 17:18 by
Modified: 2016-01-14 12:55 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2015-11-24 17:18:54
ОС: regular-wmaker-latest-x86_64.iso
Репозитории:
rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus
x86_64-i586 classic
rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64
classic
rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch
classic
Условия воспроизведения:
1. Установленный в системе пакет libpq5.7 (устанавливается по зависимости
вместе с пакетом LibreOffice)
# rpm -qa libpq5.7
libpq5.7-9.4.5-alt1
# rpm -qa LibreOffice
LibreOffice-5.0-alt2
2. Дать команду на установку пакета postgresql9.4-1C-server:
# apt-get install postgresql9.4-1C-server 
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libpq5.7-1C monit-base postgresql-common postgresql9.4-1C
Следующие НОВЫЕ пакеты будут установлены:
  libpq5.7-1C monit-base postgresql-common postgresql9.4-1C
postgresql9.4-1C-server
0 будет обновлено, 5 новых установлено, 0 пакетов будет удалено и 0 не будет
обновлено.
Необходимо получить 4909kB архивов.
После распаковки потребуется дополнительно 23,3MB дискового пространства.
Продолжить? [Y/n] y
Получено: 1 http://ftp.altlinux.org noarch/classic monit-base 5.15-alt1
[16,7kB]
Получено: 2 http://ftp.altlinux.org x86_64/classic libpq5.7-1C 9.4.5-alt1
[116kB]
Получено: 3 http://ftp.altlinux.org x86_64/classic postgresql9.4-1C 9.4.5-alt1
[1048kB]
Получено: 4 http://ftp.altlinux.org noarch/classic postgresql-common 1.0-alt8
[4448B]
Получено: 5 http://ftp.altlinux.org x86_64/classic postgresql9.4-1C-server
9.4.5-alt1 [3724kB]
Получено 4909kB за 4s (1058kB/s).                  
Совершаем изменения...
Preparing...                
##################################################################################
[100%]
file /usr/lib64/libpq.so.5.7 from install of libpq5.7-1C-9.4.5-alt1 conflicts
with file from package libpq5.7-9.4.5-alt1
E: Ошибка во время исполнения транзакции

Ошибка установки пакета postgresql9.4-1C при тех же условиях воспроизводится на
бранче p7.
------- Comment #1 From 2015-11-24 17:53:16 -------
Временное решение, предложенное Андреем Черепановым в этом сообщении
https://forum.altlinux.org/index.php?topic=35913.msg270899#msg270899

# apt-get install postgresql9.4-1C-server libpq5.7-
------- Comment #2 From 2016-01-14 12:55:56 -------
postgresql9.4-9.4.5-alt3 -> sisyphus:

* Thu Jan 14 2016 Alexei Takaseev <taf@altlinux> 9.4.5-alt3
- Disable -devel
- Add conflict with postgresql for 1C (ALT:#31531)